Mac Question about Copying Files over NOT Wifi

So I was copying some filesto my local NAS and it was taking a remarkably long time across my 10gig connection.

Later I realized this is because it was using my FUCKING WIFI TO COPY SEVENTY GIGABYTES, and I don’t know why it would ever do this? How do I make wifi the last resort? I don’t want to have to shut off wifi if I don’t have to, y’know?

You may need to set the service priority on you Network settings

andy_dill –

Are you running Linux or macOS?

Andy,

This is probably the closest you can get. There might be something you can do in the terminal to make it more definitive but I couldn’t find anything. The bottom line is that if you really need to be sure you’re using Ethernet, you need to turn off Wi-Fi. That is what I do when I am remoting into others’ machines. It sucks.

1 Like

andy_dill –

I can only assume that you’re running macOS in which case you should prioritize your network services: https://support.apple.com/en-us/HT202480

1 Like

turn the wifi off.

4 Likes

Now I remember why I keep turning it back on, because yeah, why have it on at all?

It’s because Air Drop needs wifi. Every few days I have some random pic that I want on the laptop and turn wifi back on.

1st world problems, as they say.

Airdrop needs WiFi, but universal copy/paste does not. If you copy the pic from your Mac and paste on your laptop, it will work.

Or share via icloud files. Or add to photos. Many options. I use Dropbox for most of that kind of thing because I have decided that I will never turn my Mac Pro’s WiFi on again, after experiencing exactly the same issue. Cold turkey. Be strong. You can do it.

  1. Delete iMovie
  2. Turn off Wifii
  3. Achieve enlightenment

Dude you’re so close.

1 Like

That’s something you just made up.

You know what? Just leave WiFi on.

3 Likes