Accurate XML repos from Premiere into Flame, Fixed by Python

Thank you! That cedilla! … that’s portuguese things!

Thank you! XML worked now, but scales are messed. Original footage is UHD and editorial was made using HD.

Try a scale factor of 50%.

Here’s the scale at .5:

HERO_DIGI_4X5_30_MONTAGEM_out_Scaled5.xml (933.6 KB)

Thank you, guys! 50% worked perfectly! This tool saves a lot of time! Many, many, many, many, many, many, many, many, many, many, thanks!

4 Likes

I dropped an update of this script (v1.9) into the Logik Portal. It’s also below. Now the script automatically grabs the resolution from the xml. There’s a button to disable that if you need to (thanks @MikeV! )

premiere_xml_mediahub.py (42.8 KB)

10 Likes

Hey All!

Hoping some of y’all could help me troubleshoot some things. My clips are coming in 2x stretched –– any idea what’s causing this? I’ve tried a scale multiplier of .5, 2, but neither seem to fix it.

Also, I’m not finding an option to bring up a gui when I right clip an XML in the MediaHub. Is this script working in 2023 or am I doing something wrong?

Did you install via the Logik Portal?
I’m not sure it’s been updated for 2023 yet.

Is your footage anamorphic by chance?

So the Y scale is correct, and the X scale is off? If you fix X scale, does the X&Y position line up?

You’re trying to go from Premiere to Flame, right?
What resolutions are you working with?

-Ted

2 Likes

Hi Ted!

I installed the Logik Portal but not seeing anything related to the Premiere XML script when I right click. But I might be missing something?

The footage is not anamorphic. Just 3840x2160 with some punch-ins in an HD timeline.

It seems that the X scale is correct but the Y scale is half what it should be. Though when I scale the Y up in action the positioning is not correct.

Yes, trying to go from an HD timeline in Premiere to an HD timeline in Flame.

1 Like

After you install the Logik Portal, you should see the Logik option in your Flame menu (example attached). Is it there?

Portal issues aside, for a quick fix you could email me your XML, or I could email you a command-line version of my script.

-Ted

The version in Logik Portal (v1.92) works with 2023. Using a scale factor of 50% should work for you, assuming your proxies are 1920x1080. I’m wondering if you’re encountering the odd behavior where actions are imported with the wrong scale/resolution. As a workaround, copy the action fx, delete it, and paste it back on to the same clip.

This is what my context menu gives me when I right-click an XML in mediaHub.

And I believe I have installed it correctly through the Logik Portal:

Hi John, I am not using any proxies in my premiere project, just linked directly to my color renders. I did the copy paste work around, and that changed what the action was giving me, but it’s still wrong (stretched and wrong positioning).

Did you rescan python hooks? Control Alt P H

Or just restart flame application.

I did both. Nothing new showing up on the right-click menu.

Can you make sure that only xml’s are selected? It won’t show up if you have the parent directory accidentally selected.

Are there any errors in the terminal/shell?

Edit: If your footage is the same size in Premiere and Flame, the scale factor should be 100%.

Actually yes, getting this error in terminal:

Python encountered ModuleNotFoundError(“No module named ‘flame_widgets_premiere_xml’”) in unknown code

[PYTHON HOOK] An error occurred. Ignoring python hooks from /opt/Autodesk/shared/python/premiere_xml_mediahub/premiere_xml_mediahub.py

1 Like

Okay, there is a chance that the Python script, which ends in .py, isn’t compiling for some reason. For every Python script, there should be a .py AND a .pyc. Please confirm that you have a .py and .pyc for each Python script in opt/Autodesk/shared/python. If you do, then something else is up. If you don’t, then I’d suggest is to remove all the python scripts from /opt/Autodesk/shared/python/ temporarily and move them back in to that folder one at a time and see which one is acting up.

Looks like the script is missing the UI widgets file. Delete the script from your machine and try downloading it from the Portal again. Hopefully that will fix it.

Mike

2 Likes