Importing an XML to Conform and the Video tracks are not adhering to proper time on timeline

Ok Logik folks, I am really getting old and can’t remember how to resolve this issue. Have a Premiere timeline for a film that is 90 minutes. When I try to bring in the XML, some of the video layers slip shots in the timeline one way or the other. It seems it may be an issue with Frame Rate conversion, but I turned that off in the preferences and it is still doing it. This used to happen with VariCam footage back in the day. So, you had to turn of AUto Frame Rate in the preferences, and it would fix the issue. When I bring the same XML into Resolve, it lines up perfectly. I am wasting hours here trying to get this worked out and don’t have time to eye match 90 minutes of footage. Any suggestions would be greatly appreciated.

I did try to export a new XML from Resolve and it does the same thing on import to Flame. Using Flame 2021.1

I will give that a try and send it to them as well. Thanks for the suggestions.

The AAF’s from resolve and premiere both crash Flame. Off to 14 tracks of EDL outputs. Yeah.

I’m not sure if it is the same kind of problem: Since June, I’ve been seeing odd offsets of 1-2 frames on upper layers coming from Premiere.

I found importing the XML into Resolve, and then exporting the Resolve XML, and using the Resolve XML for Flame fixed the issue. You mentioned you already tried this, so I’m not sure, it may be another issue.

Autodesk CaseNo:16802522

I’m just at a loss. I tried to export the EDL’s from Resolve. The place holders can in great, but the file names did not. Only the names from the editor. THerefore, only about half the clips link up.

So, I’m gonna have to figure this out. I may break the timeline up into reels and bring them in one at a time.

I really don’t understand how Resolve just imports the XML from Premiere and then seems to find about 95%of the media in about 5 minutes, but Flame can’t seem to get any portion of this linked up. frustrated.

I did bring in the XML into Resolve, then exported it out of Resolve. The XML comes into Flame but the tracks are not lined up.

I export the tracks one at a time as EDLs and Flame brings all the placeholders in at their proper locations, but now doesn’t have the file names to relink to. I have to be doing something wrong.

What I normally do is import the footage to a Resolve bin, then import the XML and select the option to relink from the bins. For the clips that don’t find a link, I deselect conform lock in the timeline and then in the the media tab select reconform from bins. With the Conform from Bins option, you can adjust various options to see if relinking is possible. By default, Resolve if I remember correctly doesn’t have tape name included at the time of XML relinking. Once all media is relinked, I’d then export from Resolve, try the various list export options in case one works better than another, I think last time I looked FCP7 worked well.

It sounds like there might be other issues, but this is what worked for me.

I reconfirmed in Resolve by bringing all assets into the bins and then relinking to bins. All lines up perfectly in Resolve and works fantastically. Exported every combination of list, AAF, XML, EDL from resolve and either some of the timeline is all slipped all over (XML, or will not relink (EDL), or crashes Flash (AAF). I quit. I may switch to Resolve on this one. Bing info Flame the few comps and vfx I need to do and work in Resolve. Waisted a hole day on this one. Time for a strong drink and sleep. I even tried in older versions of Flame with no luck. What I see is causing this in my opinion is there is 30 frame material that was timewarped to 24. The camera footage is 24. The stock and AE stuff is all 30 frame. Flame seems to be changing the 30 frame to 24 but not forcing the TW to keep the duration the same. Seems to be rippling the tracks by the additional frame from the 30 frame. Example. you have 24 frame clips and then a 30 frame. Duration is 6 seconds at 30 and TW to 24 timeline. So, what happened in flame it keeps the additional 36 frames and moves the start of the next clip in the timeline by 36 frames. This happens regardless of having the auto time warp or auto frame rate convert turned on. Just my thoughts of what I am seeing. What makes no sense is that the EDL’s come in with proper place holders, but the file names are not there to allow for Flame to have something to look for. The file name is blank on import.


I’ll let the experts chime in more, but I do agree a stiff drink at the end of the night helps. I’ve had a lot of issues with variable framerates importing into flame over the years. It’s gotten better (especially the AAF config), however, there are always some sort of bugs to work out (especially if it’s getty images or some stock bs). This could be an import setting issue. What I have had luck with in the past that worked was exporting/importing individual frame rate edls for each group. Obviously, you’ll have to convert the framerate edls into whatever project you are working in. It’s still a pain, but usually you have the metadata that you can then tweak accordingly. I’m sure Grant or someone else will give you the scientific side, but I’ve been used to doing “band-aids” for years. Hopefully, this helps, but I have doubts in your scenario. Best of Luck!

Not sure in this situation, but if the workflow includes Tape names, EDLs should be able to relink with just Tape name and Source Timecode, and then file names shouldn’t be needed? Time to enjoy a strong drink, good luck.

Might be a long shot but make sure the first shot in the sequence is at the same frame rate res as the timeline and has no timewarps. I had an issue a while ago where the first clip of the job screwed up the rest of the sequence

I had Resolve put create tape names a number of different ways and still had little or no luck. I am checking John’s suggestion about the framerate of the first clip in each track and see what that does.

Awesome Yann checked in to get the AAFs that crashed Flame and see what they see.

More in a bit.

I did find that the tracks that were outta wack are the ones with 30 as mentioned before. The issue is that if there is a gap in front or behind the 30 timewarped clip to 24, then then it doesn’t place it correctly. I tried to put bars at the front at 24 and also followed by a clip that was 24 prior to the sequence with no love on the FCP 7 XML or AAF.

After I placed Bars at the front of each track at the timeline frame rate, I did get FCPXML Version 1.9 from the reconform in Resolve to place things correctly. The FCP 7 did not work. AAF did not work. I did get errors on the FCPXML 1.9 that some clip are not supported so they were not exported. About 15 clips. Trying to relink the clips in that timeline with the 15 errors to see if it mostly works. Unfortunately, the 1.9 XML does not include Tape names or File names, only Clip names. Given we have 2T of material, Flame takes 20 minutes or more to scan the directories ever time I need to try a relink. Waiting to see what I get. More later.

I’m not sure in your use case if this would be better, but by soft importing the material and conforming from the Media Hub it may reduce scan times, and you can set import settings once at the time of import.

1 Like

We have been working with support. I will post more once we have all the details worked out, but Yann has replicated the crash of the AAF. More soon.

1 Like

Wow @marcwellington, cheers to you for wading through this!

I’ve had two instances of something similar thing this week, one with Premiere multilayered XML and one with multiple frame rate Premiere XML.
The multilayer one brought in the second and third layer with clips in the right order, but not aligned correctly.
The multiple frame rate one was a bit all over the place with cut points out of sync with the offline. We always ask for AAF/XML plus EDL from editorial and the EDLs did work OK, so we found a way round it.
Have not had any happy experiences with conforming from Premiere.
This is on 2020.2 Linux.
Following with interest…

Conforming with Premiere XMLs kind of always gives me sudden headaches.

Especially with multiple frame rates. As others said before: cut points are out of sync and time warps are way off their desired INs and OUTs. Not to speak about speed ramps…

Also mostly none of the scalings or repos are transported.

We think, exporting an AAF via Resolve does help a little. At least, cut points and some IN/OUT are in place.

Had a XML from FCP recently which conformed nicely and without any problems.
Edit: You need to consolidate handles ot the XML on import to something like 10 to get it working. My experience…

I’ve heard, that Adobe and Avid are working together to streamline their conforming options together. I strongly hope that Adobe will adapt more from Avid than the other way around…

At least my biggest hope is the early implementation of OTIO in edit as well as in Flame and everything else… :pray:t2:


We have still not been able to get around the lengthy scan of all the clips of the 2T of the library that lives on our Quantum SAN. One thing that doesn’t make any since is why the Flame does this every time we change a link parameter or director for relinking, or go back to the conform area of the timeline to fix an improper clip. As if it forgets what it just scanned. It has been a struggle. Commercials are not an issue as they don’t have as much material to rescan, so we don’t notice it as much.

Also, we did find an issue with the AAF’s that were crashing things. There were dynamic links to other timelines in the main Premiere project. Resolve can resolve these links with no issue. Flame can’t. So, Flame either crashes at the attempt or just ignored the dynamic links all together and ripples the layer the amount of time the dynamic link was taking up. Resolve see it and you have the option to unencapsulate the underlying clips from the dynamic link. So, if you unencapsulate the dynamic links in Resolve, then output the AAF with CLIPS ONLY REFERENCE TO ORIGINAL MEDIA in the timeline layers, then the AAF will load and not crash the Flame.

Another issue is dissolves. Any dissolve or fade the goes from a gap to the clip or from a color to a clip does not conform correctly in Flame. Flame always starts the dissolve from the clip or up to the end of clip. Resolve and Premiere can have then set to centered at the front or back of clip, but this does not translate correctly in Flame, thus throwing off the timeline by the amount of frames from the gap to center of the dissolve referenced in the Resolve or Premiere project. Over time, it shortes or extends the layer by that total amount of frames over the layer.

Also, a LOT of DJI mp4 are not readable by Flame, so we are converting in Resolve to ProRes flavors that match the DJI compression. Good times. I guess no different than off-line not being able to read ARRIRAW SUP 6.0 LF files but Flame can. :slight_smile:

This info has been shared with Marta and Yann. However, we are still struggling getting Flame to see the clips to remlink to that are easily linked correctly in Resolve. So, now we are manually doing this and it has cost us a week of time. Well, normally we would have that to conform a movie, or more, but this one is a crazy fast turn.

As is life, folks who don’t know expect the world in unrealistic time frames and ever changing media formats and software.

I do really appreciate support and all the help they are throwing at fixing or developing workarounds for these issues. Thanks Support Team!


YES! this, why can resolve do it? and not flame!!! I just had this problem with my own edit. Resolve brought it just find. Kick out an XML from resolve, still had problems in flame.

its getting harder and harder to convince people to let me use flame to finish. and EVERYONE I work with uses premiere.