Gmask tracer and camera tracking

Maybe someone has faced this before… Gmask tracer with the tracer key enabled works very well but when it has a camera track applied the output is completely black, I can see the key/matte when F8 Object Solo but the output is not correct, this only happens when there’s a camera track. The Tracer’s node output camera is set to the imported camera and the gmask as well

Does anyone know what’s the reason of this?

You might have tried these already, but the most likely simple reasons are:

a) Is your output set to Comp or Matte? If you want a matte out, by the sounds of it you do, make sure you have a Matte Out.

b) Is the camera setting on output set to the correct camera? If you have the default one in there as well as a tracked camera, you need to make sure you’re using the one you want to be using.

Yes, both settings are checked. Nothing works, its like the camera shifts when output

And it’s part of the selected objects to output?

Ah yes I’ve come accross this problem. Haven’t solved it though.

Maybe there’s a hiccup between the camera track data and the Gmask settings? Double-checking that alignment might help clear things up

I think this is a misfeature in the way the tracer works inside the node. The tracer goes bonkers when the camera is animated, this was first evident to me when I was using a tracked camera in the gmask tracer, but happens with a manually animated camera as well.

The tracer looks through the default camera position to define the tracer fg/bg when in object view mode, but the mask is drawn through the animated camera. Even if your default camera is animated it looks through the default position.

I tested this with an action and a gmask with the same camera animation. Check out the video. I’ll report this to support…