M1 Mac and Promise RAID

,

Hello brilliant minds,

I’ve just taken delivery of my Mac Studio and now I’m trying to connect it to my Promise TB2 Raid.

I followed the security change doc you have to do on the Mac in order for unidentified developer installs but the drive still wont mount.

I’ve downloaded the latest drivers and utility from the promise website but still have the issue of the drive not mounting.

Anyone here running an M1 mac with a promise raid? If so did you have any issues connecting the drive

Hi John,

Yes I’m using both Pegasus 32 R8 and older Pegasus R6 units with my M1 MacBook Pro. Where are things breaking down for you in the process?

I’m on an M1 Max MacBook pro as well.
The Pegasus1 is now EOL. I get a hard crash when I use the promise utility with a Pegasus1 or Pegasus2. But as long as I stay out of the utility, I can use Pegasus 1 and 2 drives. If you have a newer pegasus you should be fine.
They have a whole procedure for getting their driver to load.
Here’s a PDF to get started…
https://www.newtech.co.jp/wp-content/uploads/product-s/mac_supported/20201209_Promise_Pegasus_Driver_Installation_Guide_on_M1_Mac_v1.pdf
IMO they’re playing a little fast and loose with EOLing people’s vital storage without an upgrade path.
The current Pegasus utility does work with an up to date Intel machine. I’d love to go to NAB to give them a piece of my mind.

Are you using the latest Promise Utility? Both of my Pegasus 2 R6s work fine with it for me. I’m with you on Promise’s EOL situation. I bought an Atlas NAS from them, it works, but was EOL in less than a year.

I just loaded it and it says it’s up to date. 4.06…
I check the firmware of my Pegasus2 on my iMacPro and it says the firmware is fine there.
I’m surprised.

I’m pleased to report that after a firmware upgrade my drives are now working on my Mac Studio. Thanks @dcrites for assisting me on this journey via our discord chat

@SamE your firmware might me out of date. I updated my drives with my imacpro and it now reports v5

I’ve attached FW image that I installed so you can compare.

R_SI_504000064.img.zip (2.4 MB)

2 Likes

I’m starting to suspect that My M1 MBPro Max is messed up from too many machine migrations. My firmware’s up to date, but the drives hard crash my machine if I run the utility. Thinking about a clean install.

1 Like

Did you do the security change on your mac

1 Like

I did a migration from my M1MBP to the Studio and regret not doing a clean install.

1 Like

Definitely followed the whole security procedure.

maybe when you update the firmware using your imacpro will fix the freeze issue. I also had a freeze issue but not again after updating my firmware using my imacpro

1 Like

That’s the version I have installed. It hard crashes my machine if my Pegasus 1or 2 drives are connected and I run the utility.

I did update the firmware on the iMac Pro. Hard freeze when I run the utility on the M1 MBP.

I had assumed it was an issue with Promise. When I get the time I’ll back up everything I need on my MacBook Pro, do clean install, then copy my files back on.

Flare 2023 doesn’t work on the MBP either. So time to clean up and start over.

Did you update to v5 of the firmware. Your earlier post said v4

Promise Utility is v4.0.6

v5 is the latest. We might be talking about 2 different things. The Promise utility is 4.06 but the firmware on the controller should be v5

To load the firmware you use the admin menu from the menu bar inside of the promise utility.

Did that. Drives have latest v5 firmware. Just verified that this combo crashes my machine into a hardware reboot.