Timewarp ML seems to have stopped working

hi all. sorry another problem! - I haven’t used timeworn ml for a few months and need to now. downloaded the latest build and installed where it said. but im getting this every time I send a clip to TWML…any ideas@?! it seems to be looking for a different machine

1 Like

so its weird - the second bin/bash line is looking for a drive on a different computer. ive trashed the prefs as listed on their site. but its still looking for a documents folder on a different computer - then says no file or directory. any one know where the prefs are for this so I can change where its looking - or anyone know another way around this??

I had this exact same problem last week on my new Mac with 0.4.4. I installed 0.4.3 for macos and it works now.

@Jonhollis do you mean you tried to install 0.4.4 on Mac? Or do you mean you tried to install the latest Mac OS release 0.4.3?

Timewarp ML v0.4.4 is for Linux only

Timewarp ML v0.4.3 is the latest Mac OS release.

the Mac one! I’m on a Mac . o.4.3 - ive tried installing it several times now. I have no idea why it keeps looking for the. other computer,. maybe I should uninstall some of the earlier versions of flame on my Mac. maybe there is something in them that’s causing the problem

what is the cv2 module it cant find?

Looks like it can’t find the python interpreter based on first error. I had that the other day on a new Mac where it expected python3 instead of python. Had to update all the matchbox install scripts to get them to work. May be a new Mac thing that they’re missing the python alias for backwards compatibility

If you have a new mac OR you have updated macOS, be careful about the presence of Python.

Python is no more bundled with macOS since macOS Monterey 12.3 (Apple stops bundling Python with macOS Monterey 12.3).

You need to manually download it from python.org

You will also need to install the various modules required by the script.


thanks for that - installed python. dont know what other things it needs. and its better but still not working. its doing everything it should but then says error again. unrecognised arguments. any ideas