Track, Invert, Paint, Uninvert not working in 2022.1

I normally will take my tracking info and copy & paste it to my action axis, then invert it for stabilization for paint, etc. and then go to reverse it back, using the same action node but without “invert” selected to apply my work to original clip, with this version of flame it doesn’t seem to line up. I have been using this method for years and suddenly am perplexed why it doesn’t quite line up… Any thoughts would be greatly appreciated.

1 Like

I am unclear why you “Copy and paste” the tracking info. It should automagically be applied when you exit the trackers.

I am doing a planar track in gmask tracer. That is getting me my shearing/perspective information.

I have found shearing to be most confusing when it comes to trying to invert.
I can’t quite remember but maybe it is that you can’t use negative in the animation curves.

Invert should work though??

It should. It always has until this version. That’s why I am perplexed. Thank you for your input though!

Are you copying the axis from gmask tracer and using that to invert (stabilise) ?

Working here (Flame 2020.3.1) :frowning:

Small comfort sorry

1 Like

Inverting just X or just Y seems to work, but doing both seems to result in a size change. I’ve tried, every now and then, for years to figure it out. I just use a 4 point perspective image instead. The numbers reverse nicely.

1 Like

Thank you. Sigh!

Thank you.

So the way I normally do this is using an action using the back input. Then copy paste the action after the paint and deselect invert. Does this not work in your version?

1 Like

No. It doesn’t work in 2022.1. Is that the version you are using?

Nope. An earlier one. That news upsets me.

What if you save the track then load it?

1 Like

I do this: I get position, scale, z rotation and 4 point stabilization, the ability to manually add and adjust all of them, and all are completely re-inverted at the end. I have used it extensivly without issue in 2022.1. This particular version can be used as far back as 2017.1 RepoMasterDemo on Vimeo. Setup can be found in the description of the video.

1 Like

Thank you!!

The invert button will not correctly invert a planar track with “perspective” on. This has been the case since the planar tracker was introduced. As long as perspective is off, the rest of it (rotation, scale, skew) is invertible.

For invertible-perspective tracks use the perspective grid in 2d mode.


Using 2022.1 here. Action Layer, Axis Plannar Tracker (Position and Scale) Invert for stabilization. Paint on action output. Feed it to a copy of the Action node with Axis Invert off. All working as expected.


OMG…Mr. Dill…I think you are the winner!!! THAT is the answer. I have recently been using perspective when doing my planar tracks. Makes perfect sense! No wonder people think you are a Rocket Scientist! Thank you ever so much!


I have to give credit to my friend Yukiko for pointing that out to me–I was sure it worked until she pointed it out. It kills me that it doesn’t work. I’m sure there are math reasons to it, but it still sucks.

I almost always leave it off and hope that it still does a decent job of stabilizing whatever the thing is.


Once again, thank you. (and Yukiko too!)