Action Outputs blank since 2024.0.2

not sure if this is a feature or a bug…

i have a large batch setup that has lots of different logos and legals all setup so i can render out brand specific overlays for 6 different packshots in three different aspect ratios.

Its been working for the past month, and i am regularly having to tweak settings as individual licensors nitpick. Usually i will rename the relevant render nodes, select those amended in the Render List then hit Render.

Only since i updated Flame yesterday from 2024 to 2024.0.2 The outputs of all the actions is black. No Colour channels and no alpha channels. I can select each Output in the Action Node and see the correct frame - but that is not getting through to the Render Nodes.

Any ideas what i might be missing here?


Maybe you need to add all of the relevant layers to the individual outputs in action again for some reason? I’ve seen things that I thought should be there disappear in the past (although not on 2024).

1 Like

I would sever the links to the render nodes and reconnect them.

1 Like

tried that - and tried with new render nodes…didn’t work.

but they are all still showing whilst inside action looking at the result windows. Its only when trying to get a feed out of Action that nothing is getting through.

surely if the data needs re-attaching, it would nt be visible inside Action?

Duplicate the action node?. If that doesn’t work copy paste all the hierarchy inside action. Of course that requires all the inputs to be connected again. Sometimes action nodes get corrupted.

Hate to be the person that suggests this, buuut, have you tried some mux nodes on the outputs?

1 Like

no - but willing to give it a try!

1 Like

In the “Output” menu of Action, I would try to hitting the “all objects” button. You might have to ALT-E and re-select the items that will show on each output.

1 Like

I tried that also…made no difference.

I will be trying to create a new user tomorrow as i forgot that odd little problem solver earlier!

How did you migrate the set up to the new install?

I didn’t…it was aproject created in 2024, then simply re-opened in 2024.0.2. No need to migrate between minor upgrades.
Have since tried to open in just 2024 but the issue remains.
don’t want to have to rebuild this!

If you have the original version on an archive, I would try loading it afresh.

I have an earlier version that was created in 2023 - and the Actions behave correctly, but there has been a huge amount of licensor amends made since then, on the newer 2024 version. I’d hate to try recreate those again.

I have opened them both up…the earlier one works, the later one doesn’t. I did notice some weird behaviour - When in Action - the Action output shows both foreground and alpha correctly, yet try take an output from Action and its blank. If i feed an image into the background channel of the action, that background becomes visible in the output but the graphics remain out of sight, as does the alpha channel.

So something is getting through the action…just not foreground stuff.

Even tried duping the Action and reconnecting - still broken.

I would delete all the outputs from the actions and re-add them. It should be way faster than a total rebuild. Just try it with one first. Also, not for nothin’, but I have been tripped up a gazillion times by having the surface highlighted for an output, but not the axis above it.

i just imported the working batch setup into the broken one, and its still not working.

I’ll try delete the outputs - about the only thing i havent tried yet.

I have a feeling tomorrow will be rebuilding this from scratch!

you Genius sir!

thanks Tim - seems deleting and recreating the Outputs has solved the problem. I don’t know what caused it but at least i can finish the job now!

How You Doin Hello GIF by SVT