Flame UI and graphics glitches while working on batch

HI All

While working in batch setup random display issue is happening in all machines
recently updated to version 2022.2

Hi Benny,

I’ve seen the first one. I’m running 2022.2 on Linux with a P6000 GPU. It goes away when I relaunched flame, which makes me think it’s a GPU memory leak. Def report this to support. The fact that you have a video of it helps!


I had it too on a MacPro with Monterey and 2022.2…

Very True Detective no?

1 Like

Thanks for replying
yes after relaunching it goes, but its happens many times and in peak of work its frustrating to quit and relaunch again.

got temp solution for this
Delete matte output from action or replace axis in action.

I’ve seen this error happen quite a few times now when Action has a second output or matte. I get my whole UI desktop as a bg in the comp. This is what I get.

I will let support know.

I haven’t seen this one before and I can’t say that I feel like I’m missing out….

yeah not much fun when trying to push a few outputs out of Action. Seems to also happen only if you connect a matchbox to the Action output.

Just ran into this one and it terrifyingly would not go away after repeated relaunches of the software, nor after doing the init 3 / init 5 dance to kill and resurrect X. I was able to walk my batch tree and trace it to an action with a few unusued outputs. I sacrificed them to the Flame Gods, and all is once again normal. Yeesh!!

on matte setup there is an option where you can change or switch between your current selection like incase if you have selected comp just change and select comp again …the ghost image disappears.

one for our Sr. Flame editor ( Soham ) find out this workaround for this solution


FYI, I reported the bug to support and got this reply:

My name is XXXX from the Flame Support team. Thanks for reporting this issue to us. The issue has been reported to us and acknowledge the issue. The dev team has worked on it and determined the fix. The plan is to incorporate the fix in the upcoming minor release for 2022. So please watch out for the upcoming release announcement. For your reference, here’s the issue ID:

FLME-59480 Corruption displaying the result of a non-default Action output

We have also created an article to document the issue, please refer to the link below:

GUI reflects the image into Player window when rendering in Flame 2022.2

Same problem with 2022.2 both linux and mac

I also have this glitches a lot. It’s feels kinda random. Sometimes it comes up as soon as I turn on motion blur in Action. sometimes, after a certain node. I found some workarounds by pre rendering a matt output from action, before rendering the whole batch. But it’s quite annoying. Sometimes the outputs in action seems all fine. But when I render the batch, it still gives errors. Hope it’s fixed in next release.

This problem has been fixed in the 2022.3 Update version.


I faced with same bug on 3 linux z840 machines.strange thing is when we first installed the 2022.2 there was no such a glitch on few days later that started time to time after 2 weeks almost all the time happening and relaunch Flame or creating new outputs not a solution. Today updated one of machine to 2022.3.First 5-6 hours worked awesome after it started same bug again time to time.Hope develipers gonna find a solution