Flame Python Console - help() doesn't seem to return any results

Hey all, I’m a Junior Artist cutting my teeth on flame and python scripting. Currently following along with this video: Logik Live Episode 7 - Python scripts for flame

At 23:16 Fred runs help(ws) in the python flame console to get the attributes and methods associated with the object ws (which was previously defined as ws = flame.projects.current_project.current_workspace)

However, when I run ‘help(ws)’, I get the following:

Help on PyWorkspace in module flame:




I know the examples in this vid are python 2 and flame has moved on to 3, however I’m unsure as to what is causing this discrepancy. Running print (ws) gives the expected result: <flame.PyWorkspace object at 0x7f0e6ced2ba0>

I’ve got little prior knowledge related to scripting and python (and flame haha) so likelihood is high I’m just doing something stupid, but wanted to reach out either way.

Currently running Flame 2023.1


Oh boy answered my own question, needed to add brackets to my object, help([ws]) worked as expected. I am a silly goose.

1 Like

Did this thread make anyone else happy? From the avatar to the fact that it’s a flame junior wanting to get their Python-on, to the fact that they solved their own issue all while being kind and humble.

Kinda made me happy :heart: Thanks for that @gestalt_state


Cheers dude!