Flatten / merge top layer of every shot in timeline

curious if anyone has to do this as much as i do for certain tasks (rate conversions, specific exports, etc) up until now i’ve been using the tried and true @cnoellert desktop paint trick but i imagine this is possible now with some python or a new feature i’ve somehow overlooked… TIA

yeah Tim, everynow and then I get a few stubborn timelines that have certain clips render black on export to QT, even though the timeline displays fine. It’s always the jobs that seem to hang around too long! I’ve been sticking a dummy 2d transform or running the render thru paint to make it play nice.

1 Like

I used to have exactly that black clip problem when mixing h264 clips into a sequence with “proper” rushes. Since realising this i have converted them before import and not had the problem since…probably not related to the initial post but worth being aware!

OMG that ‘renders as black’ but looks fine on the timeline thing has driven me insane in the past

1 Like

maybe Python Warrior @john-geehreng has something up his sleeve

The only way to do it for now would be to create a custom shortcut on Merge Tracks

  1. Open the Keyboard Shortcut Editor while the Timeline is visible
  2. Select Merge Tracks from the Timeline Gear menu while the editor is open.
  3. Set and Save
  4. Close

and then use that shortcut in a python custom action with flame.execute_shortcut(“Merge Tracks (Button)”)

The problems with this approach are:

  • The script can hardly be shared in the community since it uses a custom shortcut.
  • You will need to recreate the shortcut every time you create a new user profile.

Please submit a request to for Merge Tracks to be in the API. That would make that possible out of the box.

OOOoooooo where can I get more info about this awesome paint trick? was there a posting before that I missed? @TimC

@ace_elliott - it’s been around for awhile, @cnoellert is the clever fellow who figured it out, or at least that’s who i picked it up from. if you have a multi-layer timeline, hard commit the top layer, take it into desktop paint, advance forward a frame or two and then when you exit on the desktop will be a single layer edit of your conform. you lose all the edits, meta data, etc. but i use this all the time to reformat a master for certain deliverables or frame rates. if you try to convert rate on a multi layer timeline, flame will go thru and convert every layer which is super time consuming and wasteful as you usually just want whatever is on the top stack.


Ha! While I’m definitely not a python warrior, I was thinking something like this might work for you. I have it deleting all audio channels because I usually have to swap the audio anyway for a framerate conversion, but if you want to keep them that’s an easy fix or maybe a separate section of this script.

It uses “flame.execute_shortcut” a few times, but no custom shortcuts so I don’t think it should go in the Logik Portal.

better version w/option to keep audio:
flatten_timelines.py (6.0 KB)

1 Like

I was burned by a similar problem yesterday.

A timeline I exported from Flame as ProRes444 looks fine when imported back into Flame, yet both QuickTime player and MediaEncoder fail to display or convert two segments and those segments are black in the encoded file. Unfortunately in the heat of the moment, one such spot has been delivered to channels and due to lack of automatic qc on the side of the delivery platform (namely Peach) been aired. “We only check the uploaded file for format compliance” was their comment…

Ouch….i’ll have to watch for that as i use Peach. Used Adstream until recently and i know their qc catches those pesky black shots!

This has been a bug since the Tezro days, and also burned me last week. It’s super, SUPER obnoxious. We thankfully have a dedicated QC team that caught it, but ugh.

I just add a track to the top of the TL and commit it with space-h, and export. No black holes.

1 Like

i always do that and sometimes the black still happens. you don’t play it down before export because up until that point (before you hard commit top layer) everything shows up on playback. its some weird thing that triggers an invalidation in the timeline when you go to bake it

Weirdness. What about pulling the committed layer out and exporting just that flat track, with no layers with metadata beneath?

And my experience involves a Quicktime export that is just fine when imported back into Flame yet has the black segments in quicktime player and Media Encoder. Which is another level of weirdness.

For those black holes that refuse to render for export: add a cc to a layer above and commit that. The cc triggers something which is useful in the situations.


I experienced that a few time and investigated a little on that.
I found out that it was a problem with Alpha channel embedded in these ProRes4444 files.
For some reason, on some shots, you’ll find there is a Black Alpha channel and that is why Media encoder or QuickTime sees and displays them as black.
Flame seems to handle that well though.

My workaround was simply to uncheck the Export Alpha from the ProRes 4444 preset.

Hope it’ll help.


This is indeed the case with my problem. Thank you.

You’re welcome; So happy to be able to help for once while I benefit so much from that forum (including your amazing particles knowledge) all the time. :slight_smile: