Logik Discord Changes

Hello Logik Community!

Yesterday I worked with Randy and Andy to add some extra security features to our Discord server. Previously anyone with a link could just waltz on in and join, chat, and listen in. We’ve changed that yesterday, and now there’s just one more step to go through before we’ll give you access. There are a handful of you who I recognized and I’ve already given you the access that you need, but there are a lot of you that don’t have access. If you don’t have access, the Logik Discord will look like this:

The only channel you’ll be able to see is the Access channel, which you should be in by default. To get access, I’ll just need you to write something that helps me see that you’re a Logik member and not just some malicious robot. Preferably write your forum name and I’ll just give that a double check and give you access. Then, the Discord will look more like this:

Notice the additional channels! This change is part of our plan to take advantage of Discord a bit more for anyone who is interested, and this is the first step in ensuring there’s at least some security in place. Hope this makes sense, and if you have any questions, just let me or the other admins know.


HI Jeff - tried to load up the discourse page, and after signing up, all i get is the access page, and a window full of blanked out entries. I can’t add a message and all the messages fail to load.


Hey there @Lightningad . That’s strange! I found your username and I gave you access, so check again and see if it’s still weird. If it is, send me a screenshot of some of the weirdness and we’ll try to go from there, but hopefully it’s fixed now.

1 Like

hey Jeff…ohh, its getting weirder…

if i click the discourse button on this pages header i get the message

which i got this morning when i first tried to access it…but since that first time, i cannot get any further because i’m now seeing…

Is the Discourse content any different to the stuff here on the forum?

Its possible the IT chaps here at work have got a firewall blocking it - they seem to like blocking random sites with no warning.

1 Like

Yeah that sure is weird! I know that if you have Discord installed on your computer it will try to launch the app, but if you don’t have the app then it should try to launch in the browser. But if what you’re saying is right it doesn’t seem to get over to the page, then yeah it may be related to some firewall stuff, but it’s very hard to say for sure!

Maybe try using a different browser if that’s possible? Like Firefox or Chrome.

i’ll try from home…detest Chrome and avoid it if i can!

1 Like

Hmmm…on the ipad at home…

Was using the laptop whilst at work, this is first time opening discourse on this device.

Interesting! Which link did you click on? The Discord link at the top of the Logik Forum’s page? We’ll have to look into that.

For now try this link:

Correct…top right hand side.

Are you running an older OS by any chance? Cuz all the Discord links work for me on every browser / Os / tablet / Mac / phone I got.

Updated the ipad this weekend, so that is. Laptop is on Catalina, so not the very latest but not so old it should be having problems.

Im gonna just stick to this forum…have more than enough social media platforms without adding another.

This is correct here. Just accept the invite and post in the Access channel and Jeff will grant your access

Its accepting the invite that causes the error. I cannot get any further than hitting accept invite, then i get a message saying the address is invalid.

Copied the link into Chrome on ipad and tried again. Hit accept causes a different error message, but stops progressing at the same point.

Hitting allow just seems to trigger a loop…accept invite, allow, accept invite, allow…….

Okay, dumb question, but, did you install the Discord App?

1 Like

Dumb answer…nope!

I thought it was supposed to work in a web browser.

…and just like that, the problem was resolved!

Shuffles away sheepishly.

1 Like

I have 10.13.6, I don’t know if that helps