Path translation resize problems

Hi there…

I am having a problem with path translation. I have just finished on a job where all my media was soft imported, and then I have sent all my batch setups without media as an archive, and then uploaded a folder with basically all the media separately.

They have loaded the archive and changed the path translation and all has worked and is re-linking. The problem has come when they compared the results of the batches to my final renders… There has been a shift in the cg elements of a pixel or so.

After screen sharing and back and forth with @richmckeand, we (him) have seemed to narrow it down to one thing. The cg source resolution in the metadata is 2457 x 1687, and when you just import it normally into Flame, it is automatically doing a resize and now showing it to be 2458x1687 and has a fine black edge on the right side of frame coming from the extra pixel. But, when linking using the path translation, it is handling that resize differently, as apart from the pixel shift, there is some resizing issues around the highlights etc. It looks like it is doing a resize from the left side as there is no difference on that side, but by the time it gets over to the right, it is quite evident.

Has anyone come across this before, or know of a solution to how it handles this in path translation?

Also, if we try to cache one of the path translated clips it completely corrupts(see pics).


ps. We did a test with a frame of the cg resized so divisible by 4 and archived a small setup with separate media, and as it wasn’t having to do any type of resize, all worked as expected.

Using Flame 2022.3 just FYI.

2457 is an unsupported resolution, thats why it’s being resized to 2458.

Yep I get that, but the way it is being handled is different when importing compared to path translation. Importing just adds a black line on right of frame, but the path translation tries to resize and introduces some edge issues.

When the artifact is happening, is the resize exposed to you? Or is this something under the hood?

Hey Randy,

No it was all under the hood…

Resizing issue around the highlights might be Lanczos or Shannon on a linear render? Perhaps? Just a guess, highlights are normally where I realize Im using the wrong filtering.

Yeah, I’m wondering it does look a lot like negative numbers from Lanczos.

This is a complete longshot. But what happens if you change the default resize in Flame preferences from Lanczos to Mitchell and re-run the restore with the path translation?

I remember this old thread, and I do remember that there may have been some inadvertent filtering in the resize module that was fixed in the last couple releases.

Actually my solution (no longer applicable to that problem since it has since been solved by Discreet) was to switch to fill, switch to bicubic, then switch back to centre/crop. It was a weird workaround, but it did the trick. I don’t know if it is the same issue here, but I don’t really know the math. I just tried shit until it worked.


Yeah, the cg is all in Linear so figured it was a filter thing for the artefact’s, but it’s the shifting/resize of the image as well. I’ll try the default resize thing in preferences and see what happens!