Ryzen 5950x + x570 build

Hi Flamers,
i am about build a system with the above CPU and x570 chipset.
I think i will have dual boot on separate SSDs , linux for Flame//Blender and windows for adobe products.
A quick search in fb group reveals this Facebook Groups ,by mr Ashby ,which is with 3900x cpu.
On another google search about centos compatibility (cant install centos 7 or 8 on amd x570 MB with ryzen 5000 cpu - CentOS) it doesn’t look promising.
Has any of you tried with the newer CPU?
Is it a bad idea to go for it?
It’s ruther expensive CPU (950euros in Greece).

Responding after a long time just to register. But it works normally

1 Like

did you ever get this system to work? I just built the same system and would prefer to use centos 7.6 over 8.2 I could get 8.2 to work, but then couldn’t get flame to install properly. I keep hitting a dead end and got a kernel panic when i booted up 7.6.
I also ran into some nvidia / xorg issues, but that i was expecting. It’s driving me nuts how I keep getting stuck.

I have built this system myself @blakieman but haven’t tried in 7.6.

8.2 works perfectly. why couldnt you install flame? and what are your nvidia / xorg issues. I can probably walk you through them. One thing I learned with 8.2 + nvidia with ryzen is insuring that above 4g decoding and resizable bar must be turned off otherwise I would intermittently not be able to boot into xorg.

i did manage to set it up. From what i remember i had to go ,indeed with centos 8.2 AND flame 2022.
2021 and back wouldn’t work with 8.2

my problem was with flame itself. I had no problem getting the autodesk 8.2 on and the correct DKU to match the version of flame i was installing, but everytime I completed the flame install i would get the same error. i can’t remember offhand if it was this


but it would always say i needed to reinstall. I hadn’t done anything custom. just the autodesk install + correct DKU + flame install.

so to fix this i tried different DKU and got the same result.

I will try again soon though knowing you got it to work. I was trying to install flame 2022.1

might just try base 2022 next.

Whats your GPU? I believe this has to with the Nvidia driver. If you install the driver with the --install-libglvnd it might solve this issue. But I haven’t had to do this in some time so it is surprising…and definitely DKU_16.4.0?

Alternatively, as nonsensical as it sounds, did you perhaps turn auto-login on? if its not the nvidia driver it might be this. I’ve been unable to launch flame because of auto-login but I think the error was maybe related to qt.


There are a couple of command lines you need to enter before and after installing Linux 7.6 to get it to boot. Basically centos 7.6 is so old it doesn’t recognize new CPUs. Give me a couple of hours and I’ll post some screen grabs of what to enter and where.

I recently built a system with the lastest gen of AMD threadripper, running centos 7.6 and flame 2021.2, 16.4.0 DKU to sort any gpu issue’s.

Speak soon!


Linux install boot menu

Press e to edit

Add mce=off and then ctrl-x to install

Once installation is done and the system reboots

Press e on this screen

Add mce=off and mce=nobootlog

Linux 7.6 should boot then.

Also I used DKU 16.3.

Hope this helps!


oh wow. thank you so much. will have a look and report back soon!

these kernel parameters are only for threadripper and not ryzen

It should work with any CPU or piece of hardware throwing up kernal panics me thinks. I don’t have a Ryzen CPU to test it unfortunately…give it a go and see if it helps.

Good luck!


Yes, sorry, I meant that I have never experienced any kernel panics with ryzen on centos in the same way that threadripper does

My GPU is 3080 . ok let me take a look. I’ll go thru the process again. thank you so much @friendlyape

@friendlyape @andrewc
so i couldn’t get a 7.6 on my ryzen 5950x without a kernel panic and so I edited the install as andrew outlined for the threadripper. This did work in that i was able to start the installation process, but then it froze as it was preparing for installation. I will either go back to 8.2 or just keep playing around with rocky linux which installed easily for me and hope for a Flame distro heading that way.

You won’t have to worry about this much longer. Windows support will be announced at NAB.


You are kidding, right?

Crap… I totally forgot April’s fools

1 Like