Rocky Road 9.3

I’m 6hrs into updating my otherwise fine working 2.4.1 Linux system to 2025 and it’s been a rocky road.

At first I was stymied by what seems to be a misleading error message about encrypted disks. I spent several hours trying to make it budge. It never did. But eventually I realized that it was what came next in the boot sequence that was the problem.

For me the first choice in the install ISO doesn’t work. I have to use the 2nd option. That does install the system eventually. The DKU also installs without error, but after installing DKU 19.0.0 some other device driver hangs the boot sequence up.

Somewhere in between while debugging I installed 2024.2.1 on the system so I could contrast/compare, and then that went flawlessly, including DKU, etc. even though this is not a reference system. I had problems with earlier versions of 2023, but the final version of 2024 was fine.

Had I done more research on how picky Flame is with their hardware compatibility, I would have bought a HP or Dell system. Back then it was in the middle of the Intel generation change, and I wanted a 12th gen CPU, not the aging prior generation. But HP and Dell take longer than system builders to roll these out. So I got a system for Puget which has been very good to me on many other systems.

It’s a real PITA. Now I have to ponder whether to sink more time into debugging this, just stick with 2024.2.1 for a few more months (forgoing some valuable enhancements), or byte the bullet and just buy a reference system for Flame Linux. All of these are non-ideal.


In the meantime I have my MacStudio for urgent work. But it doesn’t have the right monitors and hardware attached. It’s only a backup system.

I’ve done several test installs of ADSK RL9 without issue. This seems specific to your hardware.

Teradici on RL9 currently in beta sucks though and that is why we won’t be putting RL9 into production yet.

1 Like

Agreed. I just rewrote the above with the updated insights… Still no joy though.

And there’s nothing particular about this hardware.

It’s an Asus ProArt Z690 board, i9 12900KS CPU, 128GB RAM, A5000 GPU, and two Samsung SSDs. Fairly generic.

You can also still run Flame 2025 on RL8.x without issue.

I expect you have already tried this but do you have the option to choose UEFI or legacy boot at startup? (Choose UEFI if available)

1 Like

you should only be doing UEFI installs at this point.

It’s true.
Although I have successfully done both - ADSK rev 002 in legacy mode and rev 004 in UEFI.
Both on the same 15 year old hardware.

It’s set to UEFI install. We’re past the BIOS settings. It seems to be a driver/hardware combination that is causing the problem. In the first install option it never gets to the point of repartitioning. Those errors are just the last thing on the screen before it hangs on some other device.

I can get it to install with the 2nd option. But then it fails after the DKU is added. There it now hangs after it sees a USB Hub, but there too I suspect actually whatever it’s doing after and hasn’t said anything about that is the problem.

I have to have this system back together mid-week for an upcoming job. I think for now I’ll just go back to 2024.2.1, as I was able to install that fine earlier today.

I’ll reconsider my option for 2025 and probably just get a different system. Install problems have cost me way to much in the last two years. I can’t keep doing that.

I’d rather be spending that money on something else, as this is otherwise a perfectly serviceable system. But such is live.

just run Flame 2025 on RL 8.x, and call it a day. That should still be supported for another year or two.

AWS flame?

I hear you. We that conversation at NAB, all the non-billable IT overhead is real.

My goal is to reduce that overhead. Not 100% sure yet what the looks like.

Did you turn off Secure Boot in the EFI?

Yes, checked that multiple times.

It’s funny. I’ve been pro Linux for the last 20 years. I must be getting old and lazy because I’m thinking a Mac Studio will prevent this sort of crap happening and then I’ve got a whole lot more options when it comes to Software, including Remote Desktop options, and the price or so called “Apple Tax” doesn’t really seem to be that big now, especially considering all the pain points I can avoid, like slow file copying on Linux. Since the performance of Mac vs Linux isn’t glaringly big for Flame now…

Sorry, this is of zero help to you whatsoever. I was going to suggest trying to update your PCI IDs but that could break stuff in regards to Flame working and you’d need to start again. sudo update-pciids
If you’re willing to t try anything. I have used that a couple of times on laptops that I decided to run Linux on and it certainly fixed a few things that weren’t working. I wasn’t trying to run Flame on them though and I was totally prepared to reinstall the OS as I was doing it for shits & giggles really.

1 Like

Actually that pretty much captures where my thoughts went this afternoon.

I predate Linux and used have jobs to work on on Unix kernels and drivers. So one could say I have an affinity to it (and Mac OS is actually just a reskinned version of Unix under the hood).

But I was considerably annoyed that it turned that difficult to update the OS on this system to a newer version of Rocky and Flame. I get the need to manage a tight compatibility matrix because of resource limitations. That too was part of one of my jobs in a previous career. So I get it.

But I made a rational choice picking this Puget built system 2 years ago on a number of valid considerations, except for not considering just how fragile the Flame matrix is.

So I spent some time this afternoon looking at what it cost me to get either a Dell, HP, or Lenovo system with similar specs that is certified (decent CPU, 128GB memory, A5000 GPU), and the answer is somewhere between $10-15K. Yes, I know some here have thrown together P620s from used and spare parts for less, but that just becomes another time sink and gamble.

So I would end up replacing a perfectly good and current system that runs 2024.2.1 perfectly well, with a not very different system for $10-15K, just so it installs without trouble. Doesn’t sound like a sound business decision to me.

Back when I picked this Puget system I was working with a system builder that I have a long relationship with, who provides outstanding support (better than HP and Dell), and who I like supporting as an outstanding small business. It also gave me access to the latest in CPU line-up at the time.

I’ve tried twice talking to ADSK and Puget if we could get their systems into the self-certified matrix. Last time only a bit over a week ago at NAB. But it has never gone beyond exploratory interest.

So I think I will stick with 2024.2.1 on this system for now, unless I’m really bored one weekend and take another run at it. I will miss the new grain tool, but it’s not worth $10K. I still have it running Flame on my MacStudio. A bit of a workflow hassle, but $10K pays for a lot of hours of workflow overhead. And for bigger comp jobs, like one I’m in the middle of, I’m likely to use Nuke anyway on a different Puget System that runs windows.

So yes, a bit of a disappointing day. But that is the reality.

As much as I like Linux and NVidia GPUs, there’s only so much IT tax I will pay for them.

Funny enough, I’m currently trialing 3DsMax as an alternative for Cine4D. And I got a chuckle when I saw that this very popular ADSK software only runs on Windows. At least I do have a big Windows system that runs extremely well.

I also just read an article on the upcoming M4 chips, first chip to run on 3nm TSMC fab tech. Could be another leap for Apple. Though the biggest thing they have to sort out is how to jump over their NVidia shadow.

On that front actually Qualcomm is coming out with a Snapdragon chip that is rumored to run Windows on Arm with similar performance to Apple Silicon, and a solution so you can keep running x86 binaries (akin to Rosetta). So you could see a version of Win10 with Apple Silicon performance and most notably do it with an NVidia card in the system. That could become interesting.


Used Dell 7920 tower ~$3k

RTXA5000 24GB ~$2K

Highpoint Card ~$1K

NVME 4TB x 8 ~$2K

Used workstations are relatively affordable in the US, and prices for seemingly exotic hardware are declining.

They can be expanded/modified/maintained in ways that Apple products cannot.

Equally, if your apple flame blows up you can take an uber to the mall and buy a brand new one.


Yes, there are work arounds, which I would include used systems among. I’m trying to avoid work arounds.

With enough time I can get my existing system run 2025. Done it before with older versions. Not a Mary-go-round I want to stay on.

And even with a used system you have to double check that you stay in bounds with certification. Otherwise you’re just on an alternate offsite trajectory.

If you ever spec’ed a Dell 78xx or 79xx system, you know how many options there are. Are they all certified, or only a subset? I can’t totally tell reading the ADSK docs. I have an older and unfortunately underpowered 7820 here which is currently unused.

Flip that and you can buy a refurbished Mac Studio at a similar price to a 2nd hand system being put together, but you get the warranty.

Don’t get me wrong, I think the PC building is also a good option but there are also good options for Mac Studio now.

1 Like

I’m going to let everyone in on our secret…

1 Like