Flame 2023 - Rocky Linux - rtx 3090 - non DKU video driver?

As the title says I have an RTX 3090 using 2023 and Rocky Linux. Flame seems to work fine but I have noticed a longer initialize when I try to use ML for example in the image node.

That being said, I would love to run a more recent version of the nvidia driver so I could use Optix rendering in Blender. I tried installing the nvidia driver before the DKU and running the DKU install with the new —keepnvdriver but I ran into multiple issues. In fact flame wouldn’t even run.

Just wondering if anyone has had any luck with an Nvidia 30xx series card running a newer Nvidia Driver?

Hah! I just made a post about this in another thread. …

I have installed the non-autodesk Nvidia driver and it works fine in every way BUT I have run into problems with the planar tracker not working (unable to set reference). I haven’t tried this on Flame 2023/Rocky yet, though.

I’ll do that now actually…

1 Like

Why not just use a proper GPU, A5000 about the same price as a 3090 and you won’t have any problems.

1 Like

Ah cool, Did you need to do anything special when you installed the other driver? What was the order that you installed them?

What problems are you referring to? I use my 3090 in my Flame box because it is noticeably faster than my A5000

I installed them after running the DKU

Alan, I got my 3090 for 1500 when it was released. Doubt I can get an A5000 close to that price. Performance-wise it’s actually not even as fast it seems. I hear you though.

Flame just wouldn’t run when I tried to do it. Did you need to remove the old driver? Or just switch to multi-user mode before installing?

what error were you getting with Flame? I didn’t need to remove the old driver, just multi-user mode as you said.

Yea like i was saying it just plain didn’t work. I should have checked the logs but I couldn’t even open it or even the setup or services apps. I’m at the in-laws for the weekend but I may risk it when I get home tomorrow and try to install a newer driver. Which ones have you tried? Curious if you still have the planar tracker issue in Rocky Linux. All I need is 470 or newer to get optix rendering in blender.

Its likely that you didnt use the --install-libglvnd flag when installing the driver. Flame won’t open without it.

I can also confirm that the latest linux dirvers (495.46) is working on rocky with flame 2023. Planar tracking is working too which is nice. I’ll update if I find any bugs…

2 Likes

Ok I’ll try that out! I’ll let you know how it works. Thanks.

cool good to know, been running into the same issue - 3090 and no optix in blender, tbf this would be the same issue with a quadro?

1 Like

correct!

Strangely, I helped setup a Flame yesterday with a 3090. Rocky linux, DKU 17, Flame 2023 and this didn’t happen.

So just to clarify, while having ADSK Nvidia driver installed and a working Flame, if you want to upgrade to latest non ADSK driver you need to run the installer with the --install-libglvnd flag?

yes, that’s correct as of 495.46

1 Like

I can confirm this worked perfectly. It helps open up my Linux install to blender and resolve as well. Thanks for the help!

1 Like

I tried running blender on Rocky Linux and it just doesn’t work…

What kind of errors are you getting? works great for me.

Just wondering: how big is the power supply on your 3090 rig? 750 w?