SetUV projector on ABC geo

I brought in an Alembic camera & geo and trying to project to it and normally flame had that setuv that would lock the projection onto the geo but I don’t see this button anymore, anyone know how to do that now?
Its similar to this video but without the setuv button , current version of flame

1 Like


In that same menu (tracking menu in the projector), you should now see an ADD and DELETE button. Click the ADD button to set the UV reference.

We had to change it because you can now set multiple UV references over a set number of frames when required for a specific task.


1 Like

@miles @grantconnor would this have been helpful last month?

Hi Grant,

Yea I saw that what I am trying to sort out to which is a bit strange, I did the warp in Mocha Pro, when I import the geo and camera and switch it to auto fit everything looks good, the projector lines up etc, however when I press that add under reference the projector image suddenly gets crazy distorted and doesn’t line up, I look at the wireframe of the geo and looks good so I can’t really figure out what its doing and I can’t seem to have it align with displace either

Ahhh I think I figured it out but not really sure why, when I switch the geo UV mapping from default to planar it seems to maps correctly, just curious do you know why the default would map it so strangely its all stretched and warped but when its either switched to planar or ball UV mapping its mapped correctly, keep in mind I am getting this ABC out of mocha

Without seeing the example and having some testing samples, it is difficult to say what kind of UVs are being produced from Mocha and how they are seen in Flame.

I know Flame uses the default geom mapping by default, but there could be other aspects that require a planar or spherical mapping.

We can log this if you contact Autodesk Support but if it works now then it is good news to me :slight_smile:


I used this feature a few times when it first came out, then it seemingly disappeared. I probably watched that video 10 times since trying to figure out what I missed. Maybe time for an updated video.

if you want to take a look here is the ABC, the track was 122 frames and I had it mapping on 122 since its a shirt turning and disappears so really its backwards tracked 122-60 or something like that

I can look to remake it with the new UI but nothing more had changed except for the ADD and delete button.


oh the confusing thing to me is that it looks like motion vector tracking and less UV not sure why its labeled as that?


This is because the projection is using the UV positioning to lock the projection to the movement of the model. This is not motion vector tracking.

Interestingly enough, I have tried multiple ways to open the alembic file in Maya to see the geometry but all I get is the camera and nothing else.

I get it into Flame and see the same issue as you do with the default mapping setting. However since I cant get to the geometry other then Flame, I think that there might be more to this generated geometry.

Will give it a few more tries.

at first I thought it was a scale thing since if you pull it into flame with default value the geo is basically ontop of the camera, again probably a mocha issue, but the flame scale kind of takes care of that but just something to flag.



However I finally managed to get the geometry into Maya and I was correct about the existing UVs being incorrect from Mocha.

When you look at the UV editor as well as the project on your geometry, you can see that the mapping is way out and the areas where you have the different colours match the distortion in Flame when you use the projection with the default mapping.

Using the other mapping models in Flame over-ride the UVs with a standard “clean” version which gets rid of the problem.

It might be worth speaking to BorisFX but in my opinion this is not a Flame problem ( But you can get around this in Flame :slight_smile: )

Hope this helps!

sweet thank you Grant!!!

The language has changed as well. The movement of the tracking params to its own tab is easily surmised, but mode “motion warp” being the only mode, I find confusing. The new options of warp, hold , freeze options … it would be nice to get a formal explanation. Also The video for 2018 doesn’t mention motion vectors if I remember correctly. Does that relate to the motion vectors advancements or the actual motion vectors of the geo as it animates. ? I could be missing it, but it’s good to know I’m not the only one.

Hi Miles,

I missed this reply a while ago and just saw it come up.

The language did change slightly as we realised there was more that we could do (and probably needed)

The term “motion warp” in this case refers to the image projection being warping with the motion of the objects in the 3D scene. We have always used that term.

Where I suspect you may find it confusing, is the technology used for different operations.

For example with the projection on 3D objects in 3D space, we use the internally generated UV mapping from the 3D objects to do the motion warp tracking. It makes more sense to just use the objects UVs instead of opting for Motion Vectors.

But if you want to do motion warp tracking on an image, there is no data. So you need to generate Motion Vectors to understand what is moving in the image. This is what is used to do the motion warp tracking in this case. You can however generate a UV map from the motion vectors to speed things up but this is entirely optional.

I will need to look at the 2018 video to see what needs redoing (rerecording if I have time) and some of the extra options for certain use-cases.

I hope this answers your questions.


1 Like