2023 Time Bar Keyframes

Question on 2023.1 with the time bar and keyframes:
If you have keyframes that are in different channels, it looks like only those channel’s keyframes that you have selected or are animating now appear in the timebar. I’m able to see all of the keyframes if I click back on the node or say if it is an axis in action, click the axis.
Is there a new filtering option that perhaps I’m missing that would allow you to see all of the animated channel keyframes in the time bar like you could in 2022? I like the functionality of seeing only the channels I’m working on, but sometimes I want to be able to jump between all the animated channel keyframes in the timebar while working.

3 Likes

Hi Ari,

As you said, the keyframes displayed in the time-bar are always based on channel selection.

So if you select a channel, you will see the keyframes for that channel.

If you want to see all the keyframes in the time-bar for every channel, you can do one of two things.

  1. Go into the Animation editor and click the SCENE entry at the top of the channel list to select every channel which will display all the curves and keyframes for the selection.

  2. Do a multiple selection of nodes (in Action or Batch) and this will select all their channels resulting in all the keyframes displayed in the time-bar.

Hope this helps!

Thanks
Grant

PS: I don’t recall the behaviour changing with keyframe display in the time-bar in previous versions of Flame.

Hi Grant,
Thanks for the response. These two actions do show me the keyframes for the channels in the time bar, but once I go back to add a keyframe in a specific channel it only shows that channel’s keyframes in the time bar again.
I just tested this again going back to 2022.2 and the behavior is different in the time bar. For example, in Action if you create an axis and keyframe the scale, then jump to another frame and keyframe the position, you see both the position and scale keyframes in the timebar. In 2023, doing the same thing, I’m only able to see either the scale or position keyframes one at a time.
If this is just the new timebar behavior in 2023, then I’ll put in a feature request. Ideally it would just be an toggle option that would allow you to see all channel keyframes of the current node in the timebar like in previous versions.

Here is a video to show the behavior. I went through all the filter options and none of options keep the keyframes in the time bar like all previous iterations of flame. The filter options will show you the keyframes but as soon as you start animating they disappear again.

2 Likes

dlevine –

I’m not liking what I see in that video – setting an initial rotation keyframe shouldn’t immediately hide all other Axis keyframes in the timebar display.

Thank you for sharing this and I hope it’s noticed by the development team.

Out of curiosity, were you using any animation filters when you recorded that video?

Hi Chris, I have tried every combination of animation filters with no luck in getting it show all keyframes. I believe “Animated_Selected (Or)” is supposed to show everything and that is what I have selected.

Hello, delevine –

Thank you for the clarification (and for checking all the possible filter combinations – that’s not a fun thing to run through).

It does seem like something has changed versus v2022.

@dlevine @creonovo @chris

Let me explain you what happened between 2022.3 and 2023…

  1. The Timebar has always only showed you the keyframes from the selected channels. It has always been the case and it wasn’t changed.
  2. There used to be a button named “Auto Select” available in the Animation menu next to Auto Key. When enabled, that button would automatically select a channel when you would drag in its associated numeric field button. When disabled you could change another value without changing the selection.
  3. In 2023, we reworked the Animation menu and we tried to streamline some workflow. One thing we did was to remove the Auto Select button and make Flame acts as if it was always enabled.

Now that you know that it is has been changed on purpose, if there is a use case where you feel that you need to see the keyframes of a channel you are not modifying instead of the channel you are affecting please let me know why you need in a request over at flamefeedback.autodesk.com and we will consider putting the option back. I just want to make sure that this is something you need rather than something that no longer behaves like you used to.

1 Like

But why? What specifically is the reason to make the default always be Auto Select? It’s frustrating to have to try and justify why it should be changed back when you haven’t provided a justification for why it was changed beyond “streamlining the workflow.”

This is a workflow killer. Why remove the button? If you want to change the default behavior fine, but taking away the option entirely seems absolutely needless.

https://feedback.autodesk.com/project/feedback/view.html?cap=5afe6c845cb3447ab36ccbd7f0688f84&uf=c662f1a72fec4f2981ecb6ed8e580b9e&slsid=5d9d0dd9b4674f5fa33088abbdfb35f3

1 Like

We are always trying to remove buttons to streamline the workflow and making the application easier to use and learn. That’s the main reason. Sometimes we are wrong and go too far.

Thanks for submitting the request at Flame Feedback.

1 Like

@dlevine @creonovo @chris @Ryland

Sorry if I didn’t get back to you sooner on this but very often when we remove something we are taking the safe approach of creating an environment variable in case users report they are missing it.

In this case, you can set the following variable:
setenv DL_ANIM_GEAR_OPTIONS 1

and the “Automatic Selection” option will be available from the Animation Gear menu.

Let me know if you need help setting it.

Hi Fred,
I was able to add the variable in. When I launched Flame, I was able to see the “Automatic Selection” as an option under the gear menu, however this still doesn’t bring back the functionality we are looking for when setting keyframes.
The behavior that we are seeing that has changed is not in the animation panel, but under the node keyframing.
The example would be adding an axis in Action. If you then select the object button on the axis node and add a position keyframe, then jump ahead 10 frames and add a scale keyframe, you will see the position keyframe indicator disappear in the timebar.
Going back to 2022.2, having the Auto Select button turned on or off didn’t change this behavior for me when I just tested it. I was able to create a position keyframe and then a scale keyframe and saw both channel’s keyframe indicators in the timebar

Hmmm, you are right. The variable works for basically everything but Action.
At this point I don’t have any other workaround that to Shift-Click in the field for which you want to see the keyframes so you do not have to change the value to see them.

Thank you for the explanation Fred.

I very much agree that it was not good to take a normally-off button (Auto Select), change its state to normally-on and then remove the button from the UI.

I always run with Auto Select off and have my animation filter settings as such:

Screen Shot 2022-09-01 at 16.10.40

I really like working with these settings – when I select an object (surface, axis, note) the timebar displays all KF indicators for that object, expands their channels in the animation display and hides all previously displayed & expanded curves and KF indicators.

This lets me work on any one of the object’s animation curves display while preserving the KF display in the timebar. This is very important as I use that KF display constantly to reference where I have animation starting and stopping without switching to the animation curves display.

Would very much like to see this change reverted in a future release so I’ve upvoted Ryland’s request on the Feedback Forum.

The Auto Select option has been brought back in Flame 2023.2 Update

4 Likes