Blackmagic Mini Monitor 4K install on Linux Procedure


Lenovo P620, DKU 18.2.1, Blackmagic Desktop Video 12.8, Flame 2024.2.1.

I ran the rpm -i complains about not being able to load the driver, as it might be loaded. Suggest reboot. I reboot. Change Setup app to BMD for Video / Audio, and the Preview configs to BMD as well.

On Flame launch, the option to turn on Broadcast Monitor is greyed out in Preferences, acting like I don’t have anything installed.

Any hints? I tried to force a reinstall via rpm -ivh --force and that didn’t seem to help.

When installing the Blackmagic Desktop Video GUI, I do see my card as a recognized device.

But, I don’t want the GUI Desktop Video, right? Justs the non one?

It’s been forever and my google fu ain’t working. Thanks!

Flame Setup, choose BMD.

I did.

Turns out that Rocky 8.5 likes Blackmagic Desktop Video 12.3, not 12.8.

I haven’t tested 12.8, but 12.7 is fine for us

1 Like

Word. 12.3 works with Rocky 8.5.

I rolled back and followed this procedure…

 sudo yum remove desktopvideo*
 sudo yum remove desktopvideo-gui*
 sudo yum remove mediaexpress*


dkms status -m blackmagic-io -k `uname -r`

showed nothing, so then I…

sudo dnf install --nogpgcheck desktopvideo-12.3a10.x86_64.rpm 
sudo dnf install --nogpgcheck desktopvideo-gui-12.3a10.x86_64.rpm 
sudo dnf install --nogpgcheck mediaexpress-3.8a10.x86_64.rpm 

Then switched Video/Audio to BMD in Flame Setup and changed all the Preview entries to BMD and launched Flame and boom.


12.7 works for me… I couldn’t get 12.8 to work either.

just installed 12.8.1 and I don’t see any problems.

1 Like

Nice. My initial install was an rpm not a dnf…so maybe I botched the initial install. You Rocky 8.7 right ?


Oh… that’s great. I’ve not tried 12.8.1. … just 12.8… thanks!