Rocky 8.5 NVidia issues

I had a hardware problem on my system (user error in the end). After resolving it, Rocky wouldn’t load the NVidia driver. I was due for a clean install, so I put a fresh copy of the Rocky 8.5 ADSK ISO on it. Knowing that the DKU has trouble with the NVidia driver on my system (default config, not a reference system), I did the manual install of the NVidia driver for the A5000 which worked fine. System was operating with NVidia driver, installed DKU with --nonvdriver and installed Flame 2023.3. Flame launched and ran good. So far so good. DKU is 17.3.

Needed to make another tweak requiring a reboot (reload BMD driver, first after Flame install) and now I’m back to the same NVidia problem. In /var/log/messages there are entries that read

Failed to initialize NVidia kernel module. No devices detected.

Obviously hardware is fine because it worked just prior to the DKU install. I did notice that during the DKU install it said something about disabling graphics. And it in fact had set the systemctl default target to non-graphics. So I reverted that. But still no luck.

Figured maybe the DKU did something funny with xorg.conf. There are numerous in the folder, labeled ‘beforeDKU_install’, ‘dku_standard’, ‘flame.v2023.3’, ‘nvidia-xonfig-original’. I tried a few of them, but no luck.

After reboot it stays in text mode with just the blinking cursor in the top left. With Ctrl-Alt-F2 I can get to a shell and login, but can’t convince it to load NVidia driver properly.

Any ideas?

1 Like

Maybe bmd driver rebuilt kernel without include nvidia driver module. I install bmd driver also but I don’t have that problem (thought I have to reinstall another drivers such wifi driver). Who knows. The simplest thing to do is , since your system is booting up in text mode, is reinstall your specific ndivida driver , to rebuild the kernel again.

1 Like

Good points. The BMD install went really fast, so not sure that built a new kernel.

But I like the idea of just re-running the NVidia install. Because that worked in the original situation.

Excellent. Thanks @kily. Re-running the install reset whatever got goofed up by the DKU install. It gave some errors about DKMS but they seemed to be inconsequential. Graphic mode is back and Flame is running.

Glad to read that. :+1: