Camera fbx export

Hello everyone.

I am exporting an FBX camera from Action and then when I import this in Nuke, it comes empty (no animation). I have tried baking all the keyframes and also most of the FBX versions, but still no success. I managed to do it in the past, but for some reason this is not working anymore. Any ideas?

Is there any chance the key frames are at frame 1 and your Nuke scripy is starting at frame 1,000?

Another stab in the dark but there is an option to bake in key frames when you export the camera. Have you tried doing that?

Thanks for your reply guys. @Randy_G that was a good shout, unfortunately the fbx, when opening in nuke, it comes completely empty (no keyframes at all), and I have also tried baking the animation using different options. And still no success. Is that a bug maybe? Have anyone had this problem before?

Is it possible to export Alembic from Flame?

I believe Alembic is import only in Flame.

I have successfully exported FBX from flame for maya before.

My biggest problem is nearly always scale and occasionally incorrect FOV.

1 Like

We found out the problem guys. It is a nuke’s bug. Flame by the default, writes the FBX extension in the file with capital letters, and the latest nuke version doesn’t understand the difference and doesn’t load it. As soon as you change the capital letter to lowercase Nuke loads it fine. Yeah, I know, it is stupid.
But thanks a lot for your help.

3 Likes