CentOs 8.2 or 8.3?

I have been playing a bit with new centos version. Only a drill installation in a pc for test. To see errors, problems for a future upgrade, to play with new gnome desktop…

I tried first with the regular centos 8.2, downloaded from centos servers. Something that caught my attention is the info about centos version installed: 8.3.2011 :face_with_raised_eyebrow: . I checked my iso downloaded. It’s 8.2.

Later, I tried with custom adsk iso. No possible errors. Only one version. And , again, it says 8.3.2011. Is it an error from original centos distro?

It is best practice to use the ADSK iso if you’re going to use the flame family products. You can use the regular centos distro, but sometimes when you install the DKU it will remove (or not install) what it thinks are conflicting packages. So if you’re comfortable with working out conflicts/dependencies, more power to you!

However, what I suspect happened is that you may have done a dnf (yum) update at some point during/after the install – which brought the kernel version up / redhat-release version to v8.3.x

The ADSK iso is at 8.2.2004 and even with the DKU 16.0.0 update, my redhat-release has stayed the same at 8.2

[root@vxfhost ~]# cat /etc/redhat-release
CentOS Linux release 8.2.2004 (Core)

[root@vxfhost ~]# uname -r
4.18.0-193.28.1.el8_2.x86_64

[root@vxfhost ~]# cat /etc/DKUversion
DKUversion 16.0.0-1
# =============================================================================
# Autodesk - 2021
# =============================================================================
# This DKU support the following workstations:
#
#       - HP  Z840,  CentOS 7.6 / CentOS 8.2 64bit
#       - HP Z8 Gen4, CentOS 7.6 / CentOS 8.2 64bit
#       - DELL T7920, CentOS 7.6 / CentOS 8.2 64bit
#       - DELL R7920, CentOS 7.6 / CentOS 8.2 64bit
# =============================================================================
# Build date: Mar-29-2021...12:25

HTH.

Wow. :open_mouth: My info of uname-r shows: 4.18.0-193.28.1.el8_2 kernel version (same as yours) but cat /etc/redhat-release shows 8.3.2011 … wt** :thinking:

I only tried to install my favorites apps (vlc, handbrake, no machine, anydesk, sublimetext, filezilla…only utilities for the everyday work) and see if they still working . I repeated same with regular centos distro and adsk iso. I was not ware at all to install any update. Of course I didn’t make any yum update. I know that it can ruin the system for flame.

Thanks for the info. I know that I have to re-check my routine for install and see what is happening here

That is strange! What does lsb_release show?

[root@vxfhost ~]# lsb_release -a
LSB Version:    :core-4.1-amd64:core-4.1-noarch
Distributor ID: CentOS
Description:    CentOS Linux release 8.2.2004 (Core)
Release:        8.2.2004
Codename:       Core
|LSB Version:|:core-4.1-amd64:core-4.1-noarch|
|---|---|
|Distributor ID:|CentOS|
|Description:|CentOS Linux release 8.3.2011|
|Release:|8.3.2011|
|Codename:|n/a|

Just chiming in, by my lsb_release output is also

LSB Version: :core-4.1-amd64:core-4.1-noarch
Distributor ID: CentOS
Description: CentOS Linux release 8.2.2004 (Core)
Release: 8.2.2004
Codename: Core

My bad; apparently lsb_release uses the output from /etc/centos-release (redhat-release is a symlink to this)

Your issue may be a bug or /etc/centos-release somehow was modified.

It is an interesting issue, so I spent a little time googling – the rest of this post is just an exercise – as you said this was only a test install.

If you can confirm that output of uname -r matches the output of rpm kernel query and cat /proc/version:

[root@vxfhost ~]# uname -r
4.18.0-193.28.1.el8_2.x86_64

[root@vxfhost ~]# rpm -qa kernel
kernel-4.18.0-193.28.1.el8_2.x86_64

[root@vxfhost ~]# cat /proc/version
Linux version 4.18.0-193.28.1.el8_2.x86_64 (mockbuild@kbuilder.bsys.centos.org) (gcc version 8.3.1 20191121 (Red Hat 8.3.1-5) (GCC)) #1 SMP Thu Oct 22 00:20:22 UTC 2020

then most likely just the /etc/redhat-release file is somehow wrong.

Otherwise you can re-install the centos-release rpm (version info is the output of the rpm -qa centos-release ) which should install a new /etc/redhat-release file

and then:

[root@vxfhost ~]# rpm -qi centos-release
Name        : centos-release
Version     : 8.2
Release     : 2.2004.0.1.el8
Architecture: x86_64
Install Date: Tue 04 May 2021 11:28:39 AM EDT
Group       : System Environment/Base
Size        : 25430
License     : GPLv2
Signature   : RSA/SHA256, Tue 02 Jun 2020 09:09:51 PM EDT, Key ID 05b555b38483c65d
Source RPM  : centos-release-8.2-2.2004.0.1.el8.src.rpm
Build Date  : Tue 02 Jun 2020 09:02:49 PM EDT
Build Host  : x86-02.mbox.centos.org
Relocations : (not relocatable)
Packager    : CentOS Buildsys <bugs@centos.org>
Vendor      : CentOS
Summary     : CentOS Linux release file
Description :
CentOS Linux release files

The modify date of the /etc/centos-release should match the Build Date of the above output.

[root@vxfhost ~]# stat /etc/centos-release
  File: /etc/centos-release
  Size: 38              Blocks: 8          IO Block: 4096   regular file
Device: 803h/2051d      Inode: 67137675    Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2020-06-02 21:02:49.000000000 -0400
Modify: 2020-06-02 21:02:49.000000000 -0400
Change: 2021-05-05 19:47:51.361814153 -0400
 Birth: -

Good luck with your production install!

Thanks jarak. The output of “uname -r” , “rpm -qa kernel” , and “cat /proc/version” is 4.18.0-193.28.1.el8_2.x86_64. I don’t have installed centos-release package.

Anyway, this weekend I’ll installed the system again and I’ll repeat all the process. I have notes about everything I do.

With that kernel version, I wonder also is it’s some kind of bug of info. But like I said, it was with original centos and with adsk iso. I’ll repeat everything checking constanty info system.

btw, anybody noticed that the hostname setted with adsk iso is “vxfhost” , not “vfxhost” ? :sweat_smile: I realized in my system, and I read it in your logs.

really? :sweat_smile:

Last weekend I repeated all again. From scratch, and always watching the info system. I figured out the problem: yum-utils.

This is a plugin for yum and to manage repos using some extra command. I was setting yum repos when I read about power-tools repo. This is a new (official) repo in centos 8 and it seems is important for install some component, specially for extra multimedia support and more interestings things. I have several utilities installed in centos 7 and one of my interests is translate all my apps, utities etc to centos 8.

Most of the tuts about enable power-tool repo start using a command for yum, using this “yum-utils”. I thought, wrongly, that I need installed it. So, executing “yum install yum-utils”, I updated accidentally this plugin, and solving dependencies, the system updated several and aparently important packages. Reading the output log console, this was strange for me. After execute “lsb_release -a” … bingo… I have again 8.3 as version number. Though I think it’s only a kind of fake info. I don’t think that system was updated at all. Anyway, I don’t want this kind of things in my sytem,

Ironically, I know how enable manually repos editing repo files. Well, mistery solved.