Curious aspect ratio error

Here’s a strange one. I need to work at 6432x4800 for a project. When I try to create an action or colour source at this resolution it assumes the aspect ratio is 1.333. It isn’t, the correct aspect ratio is 1.34. I can enter this manually or select w:h which correctly figures out the aspect. Makes no difference though, flame still incorrectly believes the aspect is 1.333 and as soon as I step out of the node it reverts to 1.333.

The problem is this error screws me up at a later stage where I have to tile a number of these 6K panels together and action incorrectly interprets the aspect ratio, leaving me with small blanking errors. I’ve tried using resize to to reapply the correct aspect but it ignores the actual numbers and assumes 1.333. I could try figure out the maths and perform a slight scale in x to compensate but I really, really shouldn’t have to do this - it’s infuriating. This crude screenshot below shows the issue clearly. I’m assuming it’s a ‘helpful’ feature relevant to when we worked in 4:3. Anyone know of a fix here? I’m on flame 2021 if that’s relevant.

Sadly makes no difference. The resolution is one that flame is otherwise happy with - ie divisible by 4 so I don’t think its that.

I’ve reproduced this too. Report it to support.

Thanks - glad I’m not going crazy. Yes, I will report it but that won’t help me at the mo’. I’ve spent the last couple of days setting this up and I’m going to have to retool it with a different resolution (which was semi-arbitrary in the first place - just unlucky the ratio happened to fall around the 4:3 mark - damn you irrational numbers!)

Same. Mac version, flame 2022_2.

Same on Linux 2022.1

I was thinking something along similar lines, but after a few experiments I’ve come to the conclusion that it is a much deeper issue than simply the colour reverting to non-square pixels. It seems to be an inherent limitation across the whole platform.

You could try to add this resolution to the list of default resolution as demonstrated here:

For more information about what file to edit please have a look at the Flame Help here:

I wouldn’t consider adding a custom resolution as a workaround but as a time saver. You wouldn’t need to manually enter that resolution every time you need it anymore.

1 Like

I don’t think there is any quick fix. It seems to consistently round out aspects that are very close to 4:3 or 16:9. Try keeping 4272x2400 at 1.78. WxH keeps reverting to 16:9 and the aspect changes to 1.778.

Yes, that’s my conclusion as well - it seems like a feature of sorts to round up to common aspect ratios. I guess helpful in some circumstances but definitely not in this instance. My solution has been to chose another resolution which has actually been helpful in other ways.

As an aside, I’m rendering very high resolutions and have discovered a couple of things: Flame 2021 handles very high resolution much better than 2022.

Also, and this is crazy but definitely true, if you try to render a multilayered complex comp at very high resolutions in action the render will take an extremely long time - exponentially longer than you’d imagine based on rendering at lower resolutions. However, if you reduce the height of your action by, say, a quarter and then render with 4 cameras, each one capturing a quarter of the original frame - your render times decrease massively - 11 times faster in my case. It makes no sense given you’re rendering exactly the same number of pixels but that’s flame for you.

1 Like

I’m guessing it has to do with some sort of memory swapping. The same thing is true when rendering timelines with a lot of layers. It is faster to render each layer one at a time than to simply render the top. I assume it also takes up much more drive space.