Disabling Linux Print Screen hotkey so Primary Video hotkey works

Hello
I had a crash and now some of my keys aren’t working. Im on Linux and use Smoke Classic settings. Flame 2021.2. I’ve tried new users but that’s not working.
The one that annoys me the most is when I press Print Screen to change to Primary Video it instead loads up KSnapshot, it’s like it’s ignoring the flame shortcut on that key, but not all keys.
Anyone seen this or got any ideas how to fix it? I’ve had our engineers reinstall flame but that hasn’t helped.
Cheers. Rob

1 Like

Ah. Yup. You need to disable a few hotkeys at the system level.

So, and pardon this, this is from memory as I haven’t been in front of a Linux machine for a long time, but what you are looking for is the place to turn off system-specific hotkeys.

Try something like:

System Settings / Keyboard and Mouse / Global Hotkeys …and then, I think there’s a pull down menu there with options…you are looking for…umm… I think KHotkeys or KWin. Somewhere in there is the Print Screen and Scroll Lock hotkeys that you want to disable at the OS level. Also, Control-ESC is somewhere around there as well. Disable those and Fran’s your Nan.

(and, hope you don’t mind, I adjusted the name of the topic to be a bit easier for others to find in the future)

And if you are lost and need some help, I’m in front of a computer and can TeamViewer in.

I don’t mind at all that you changed the subject. I’ve attached a photo of the keyboard layouts tab, the advanced tab isn’t turned on. Does any of this help at all?

1 Like

Okay go back a level…do you see a Shortcuts button one level up from here?

I don’t no.
Really appreciate you helping me here Randy

Shortcuts and Gestures!

As soon as I had another look I saw it.
So in there is Preset Actions and in that drop down is PrintScreen.
I’ve no idea how that turned on at all. Although when I had the bad crash I also lost my flame user and the desktop level looked very different when it booted up again.
Thank you for your help again, really appreciate it.

1 Like

Yup. It’s also likely that your IT friend reset your Linux user. Glad you got it!

1 Like