Rocky Linux Hotkeys

Just installed Rocky on my z8 and have Flame 2023.1 up and running.

Unfortunately my left ALT key is not being recognized properly with my Smoke Hotkeys and I’ve come to realize how much I rely on that key to switch into Batch Schematic (ALT+ESC), select nodes downstream (ALT+Click) etc.

Any advice on how to set this up so things behave as they did in CentOS? I’ve messed with Keyboard settings in Tweaks but nothing seems to help as of yet.


I’m on Flame hotkeys and experience similar. I haven’t found a good solution. Especially in Batch paint. Try switching brushes with meta-1, 2, 3, etc.

Is the Alt+Meta Keybehavior set to sth.? If yes, try to set them to ‘disabled’ in Tweaks (When these are not the settings you already played around with)

What is sth?

anything that’s not ‘disabled’, as these will have a higher priority than flame

Gotcha. Are you able to change brushes in Paint with meta?

Using smoke, there the paint shortcuts don’t need meta. But I can use all Meta or Alt shortcuts without any problems in flame on Rocky. Wondering whether this is one of the shortcut bugs, requiring a new flame user to work.

Very possibly. I have so many custom shortcuts, I have to manually reconfigure a good bit. But in this case, it only changed with the OS. I don’t think it’s a flame hotkey issue.

How is it that we are locked into an ADSK-approved version of linux, but some of our most-used hotkeys don’t work?

Yeah - I was a bit surprised that this was an issue. If there’s no way to set up the Rocky Install to default to the proper settings in the ISO from Autodesk then there should at least be detailed instructions in the installer on how to properly setup the OS so hotkeys can function.

I think that I’ve mostly solved the issues I’ve encountered so far in case anyone is in the same boat:

  1. In Settings/Devices/Keyboard Shortcuts you have to disable ANY shortcut that might conflict with your Hotkey. For me the Alt+Esc hotkey was assigned to “Switch Windows Directly.” I first tried reassigning this hotkey but it didn’t help. I had to disable it. Which is far from intuitive (at least for me). Click on the hotkey you want to change and press Backspace. Set the new shortcut as disabled.

  2. In order to restore the ability to Alt+Click on a node to select all downstream nodes I went into Tweaks/Keyboard & Mouse/Additional Layout Options and changed Alt/Win key behavior to Alt is swapped with Win. Seems to still be slightly wonky and every once in a while the Alt+Click doesn’t work. But at least it’s 95% of the time now instead of 0%.

I’ll update if I make any other discoveries. If anyone else figures out anything helpful here please let me know!



I hate the “grey box” environment constriction, but we have zero hotkey issues with RL. I’m wondering if it has something to do with the type of keyboards you guys are using.

So I was working with support and I noticed that somehow my Window Action Key in Tweaks (explain to me whey we actually need Tweaks and Settings btw?) had somehow gotten set to Alt.

I thought I had been pretty through in going through all of the setup recommended settings, but perhaps that was in my root account before I made my new user. I was also getting acclimated to Gnome for the first time and perhaps switched something I shouldn’t have.

Regardless, that seems to have help restore me to expected behavior, but I do still need to disable certain Keyboard shortcuts in Settings to make all of my hotkeys work.

1 Like

I’d say if this is an ADSK official release and these issues are happening, ADSK should publish specific instructions on how to avoid these problems.

I don’t use ADSK approved keyboards. I use higher performing keyboards. :slight_smile:

Or just fix the problem.

Important: will Rocky Linux support my Power Glove? It’s an important part of my compositing workflow!

Vintage 80S GIF

It works for me in emulation mode once you open up the permissions and run the following command:

sudo chmod 666 -R /opt/Autodesk/wrists

1 Like