Dodgy playback speed

This is baffling me…

I have a short project that i shot at 4k on a BMPCC Cinema $k camera using Blackmagic Raw. These were brought into Flame Aces project as Tagged, and set to Cache to my internal ssd framestore. I’m using 2024.1 on Mac Pro on OS 13.5.

I cut the sequence in to four long clips.
Took three of these into Batch to do some keying, used Color Management to make rgb as they seemed to key better that way.
These three were rendered out using Render Node.

Then dfropped into place on Timeline. The “clean” untouched shot plays back fine, but no matter what i try, i cannot get the rendered clips to playback at normal speed. It stutters and freezes and runs slow.

I have tried creating and rendering proxies, i exported the clips and re-imported them with Cache set to happen…same problem. I can only watch the shots back in realtime if i export out the timeline.

Just run a Blackmagic Disk Speed Test on the framestore and its giving 5989MB/s Write and 6843MB/s Read…surely Flame should be able to playback without these hiccups ??

Is there some sneaky little tip i need to know to playback my timelines?


What codec are they cached in - file sequence or some .mov/.mxf type flavor?

The speed test reports on sustained read/write of one large file. File sequences break things down into individual file operations which have much higher overhead. File sequence is great if you have to step back and forth in batch, they are far from ideal for timeline playback.

1 Like

The Batch render might be 16-bit fp and your cache format might be RAW so this will impact playback performance. Setting the cache format to any of the option using EXR (PIZ) should help. You would just need to modify the project settings and re-render to get updated cache for your Batch scene.


The cache settings (are these the ones when creating a project?) are set to Apple ProRes 422 Proxy/EXR (PLZ).

Batch Render is 16bit

Files were imported using Tag Only / Tagged Colour Space - from files or rules.

File format for the rushes is showing as BRAW, and file format for the exported (and re-imported) Rendered batch clips is mov.

I have noticed some of the clips i imported are showing as Pending instead of Cached. I have tried to force it to cache using the media options but nothing seems to change.

Should i be changing any of these settings ?

As for the File Sequence point - these are not fast cuts, and the source material came from only two shots…durations are 19s (untouched by batch), 32s, 13s, 13s.

How much free space is on Cache drive? Export and reimport back to flame cc files, are they playing correctly, try it in new project. During playback check system resources, it will show you what is used, it can be problem with PLZ compression (decompressing EXR is CPU based). Change Batch render to 10bit and check that, it can be problem with 16 bit.

1 Like

Hi Viktor,

there is over 7 tb free space on cache drive.

What do you mean by cc files?

I’ll try the 10bit suggestion as soon as i get a chance.


ok, so no problemo here (some drives, when they reach 80-85% of capacity, slows down rapidly).

CC - color corrected

Are you comping rendered 3D? If you are not using EXR, than stick to Prores or uncompressed. EXR, if not treated correctly can become huuuuge, and can kill any system. See Mr. Slabrie comment.

Is it first time that this problem occur, or do you use this workflow first time? Just for sanity check, try recreate those steps in Davinci and see if it plays.

1 Like