Flame 2022 NDI - no image on Mac

OK, this is prob an edge case, but…

I’m trying to watch the NDI stream on my Mac. I’m connected to my flame at work via VPN. I can see the remote machine in the NDI Video pulldown menu, but no picture and no sound.

Any ideas?

1 Like

And Im assuming you have selected the NDI output in the Flame Setup application, and have an active Broadcast Monitor timing set in Flame Prefs?

Yes. It’s visible on a windows machine connecting via VPN, and a Mac or windows on Prem.

1 Like

Umm…ridiculous Catalina permissions?

Or its a VPN / network config problem. You can obviously ping Mac from your Flame and vice versa?

Yeah. It’s gotta be something like that. Or something firewall related. We’re gonna try some other stuff tomorrow. I’ll report back.

1 Like

try the pings first. see if they talk to each other.

and a quick google…

Yes, they can see/ping each other. NDI video Monitor can see the name of the flame that’s streaming. Just no show.

SOLVED! I was experimenting with trying to see if I could see the NDI feed inside of OBS. That lead me to installing the NDI plugin for OBS which had a dependency: ndi-runtime-4.5.1-macOS.pkg. After I installed that I got video & audio from the NDI video monitor on my Mac. w00t!!!

Office Flame on the left via RGS. Watching the feed on my Mac on the right through the company VPN.

1 Like

Hey guys… Im a bit late to the NDI party, and I’ve got some issues.
I can see the VFXHOST Flame video fee on my Mac’s NDI monitor, but all I get is a black screen.
I have firewall OFF on the Mac, and I just installed the ndi-runtime-4.5.1-macOS.pkg
still no luck

Any hints???

Check that the ndi set up in system prefs is set to the correct rez / timebase

Is this Helpful?

Hey Randy
i went thorough that video… and I think I’m doing all correctly.
The only thing I can see now is that in the Flame Setup, on the Preview tab, on the bottom left, when I set that to NDI, it does not stay like that.
If I close the Setup app and open it again it shows “aja” instead of NDI.
Could this be the culprit??

1 Like

But then again… when I start Flame it looks correct on the terminal… it’s all mapped to NDI

1 Like

Hello Inti!

Setup / Preview / Preview Device selection at the bottom is only a shortcut to set the Preview device for all timings in the list. Save the file when you have set the Preview timing to NDI and there you go. When you restart Setup, this shrtcut goes back to AJA since it is using the first option in alphabetical order. This is not important since the cell next to your Timing is the one that matters.

I guess you have enabled a Preview timing in Flame / Preferences / Broadcast Monitor / Timing, right?

Could you post screenshot of Setup app (General & Preview tab) and Broadcast Monitor Preferences in Flame so we can see what you have?

Thank you so much for doing this man…
I tested this at home, it all worked fine broadcasting from the Linux box to the Mac.
But now… Im not at home, Im on a different environment.
I think this is not a Flame issue but a Network/Mac issue… But yes, let’s double check.

Here’s the screencaptures

I can see the NDI source on the Mac, but it’s only a black screen


Hey did you get this sorted? Wanna screen share today?

Hey man, what a nice surprise!

Not, it’s not solved yet
I would definitely try to do the screen sharing thing

Let me know how to proceed


1 Like