NDI Audio on OBS Windows...does it work for anyone?

Hey friends,

I’m trying to go NDI from Flame to OBS running on a windows machine. OBS sees the NDI signal and I get video…but no audio. I can hear the audio in NDI studio monitor for windows. Anyone seen this or have any suggestions?


Out of curiosity, go to the Help menu on OBS, Log Files, View Current Log.
Scroll down a ways; do you see a couple lines like:

16:08:01.800: avresample_open failed: error code -22
16:08:01.800: creation of resampler failed

Thanks, Bob. I’ll check it out in the morning!

Yes! I’m getting that error. Have you found a way around it?

Unfortunately no. There seems to be something “different” about the NDI stream from Flame; if you have NDI Tools installed, you can use the Test Patterns program to transmit bars & tone and if you select that as your NDI source in OBS the audio gets there. So at least we know the NDI plugin should work.

Conversely, Flame’s audio does come into the Studio Monitor program correctly.

The other thing I see in the logs in OBS with Flame is it instantly tries to add over a second of audio buffering and then dies with “Max audio buffering reached! total audio buffering is now 960 milliseconds”. So I’m not entirely sure what’s going on, if the audio is coming in with different timestamps freaking OBS out, but other NDI apps are more tolerant, etc. I don’t know enough about the technical innards of NDI. I guess the devs will have to take a look at.

Try Streamlabs OBS. That worked for me on Mac when OBS for Mac would crash instantly. Might be worth trying on Pc.

1 Like

Hi Andy,

I just tried the Music Edition fork of obs studio (16 channels!)

and it got audio from flame.

I had looked at the NDI analysis tool and saw this:
NDI version :

15:41:30.854: Video receiver creation succeeded.
15:41:30.854: Audio receiver creation succeeded.
15:41:30.875: Audio connection opened.
15:41:30.881: Tally program=false preview=false
15:41:30.910: Audio format changed. 48000Hz, codec=NewTek Mode 0, 16 channels.

and on the obs studio forums, one person said that obs wasn’t able to select channels from multichannel


1 Like

Same here

Ahhhhh… indeed, 16 channels. I didn’t even think to look at that, as my monitor setting is always set to Stereo Downmix in Flame but I didn’t consider the IO was still 16.

Welcome to The forum, Janice…and THANK YOU!!

@Brooks . Is this the problem you were having?

@randy YESSSSSSSS, I just installed that version of OBS and blam-o! IT WORKED! That has been plaguing me for ummmm. months!

This has made me happy! @jarak08 thank you for this! It will be such an improvement.