Flame 2023 on Rocky Linux install problems

Hi Flame wizards,

Has anyone tried the Autodesk Rocky Linux 8.5 ISO? When I boot to the USB it only gives me the manual partioning option which leads to not being able to find the ISO to install in the GUI.
If I use the generic Rocky Linux ISO from their website I can install Linux fine but can’t install DKU 17.0, I get an error message saying the DKU must be installed on CentOS…
So far have not been able to find an Autodesk install guide.

Machine is the P620 certified spec with 2.5 SATA SSD for OS.

Cheers,
Alain

1 Like

Installed RL 8.5 plenty using the manual partition on many differs machines, including P620 without issue.

Hi Alan, I receive the below error when selecting the “Autodesl Flame Workstation” manual partition option.

Make sure you are set to boot uEFI only and also have Secure Boot turned off. Additionally, likely the way you are burning the ISO to USB is not proper.

Thanks for your reply Alan. Confirming I have turned secure boot off, where in the BIOS can I force UEFI boot only? And can you please tell me the correct method to create the USB installer?

on Mac or linux:

sudo dd if=/path/to/iso of=/usb/stick/path bs=1m (on linux it might be capital M)

I have seen that command in the Autodesk support literature but don’t understand how to use. Can you please give me an example of what the command would look like in your system if the ISO is in the Downloads folder? And this is a brand new USB stick with no file structure? Where does it normall mount to?

Just use Balena Etcher. It’s drag and drop and and I use it all the time. Avail for free on every Os.

2 Likes

When you get to that “Error setting up base repository” point it here:
https://download.rockylinux.org/pub/rocky/8/BaseOS/x86_64/os/

Also for the ISO creation - I started with a Windows PC and no linux. So to create the Rocky USB stick I used Rufus on Win10. That worked perfect with the autodesk iso.

Alan

I am finding dku 17, rocky 8.5, threadripper pro, gdm error seg fault 0 on boot. Nvidia Driver cannot load. Nvidia believes it was probably compiled against the wrong kernel version dev and headers.

Rocky works with the newest Nvidia Drivers (which compile on install) , but doesn’t seem to be work with the old version included in the DKU17.

Have you seen anything like this Alan?

No, I’ve not seen that before. What GPU are you using/?

Most likely your Rocky USB key is not reading the kickstart file. I suggest trying another burning app, like Rufus or belenaEtcher

When it’s properly reading the kickstart file, it should be automated to the point it stops at the “press enter to reboot” when it’s completely finished.

I have Nvidia rtx A5000, rtx A6000

I didn’t dig too far, but here’s how I fixed it.

Blank SSd

Install ADSK rocky8.5 iso from USB flash drive Copied via dd

Install the custom nvidia driver run file found in the DKU system_rpms (this is a pain in the ass that includes blacklisting nouveau in the grub loader and in the initrd, rebooting in non-graphical mode, and running the ADSK nvidia .run file)

Then reboot

Then you have an ADSK patched nvidia driver running on ADSK rocky 8.5

Then you run the DKU installer.

Then everything works fine.

I have not investigated why this fails, but I suspect that the DKU is not blacklisting nouveau properly, and I suspect it’s in the initrd, but I’m not certain.

Since I did that successfully before the DKU, it may not need the driver installed before the DKU… If i ever get the time (lol) I may try that.

Thanks for your input!

Hi, I’m on a Ryzen with an RTX 3090. I have a fresh install of Rocky Linux 8.5. I installed the DKU and the latest NVidia driver, following a couple of guides. When I install Flame 2023, it gets partway through and then throws Error 1 and fails. Any thoughts on how to fix that?

1 Like

@Sean1985 did you ever find the location of the installation log? var/log/autodesk?

Leaving this for whoever else has this problem. I was able to get my installation done.

There’s an Autodesk Installer Log Collection Tool, which will help find out why the installer is crashing.

In my case, it was missing dependencies. I looked through the Summary file, and installed all of the Dependencies. Then ran the installer, and kept running the Tool until I had installed all of the new dependencies it was finding along the way.

It seemed like, from the log, that the installer wasn’t able to get online and grab stuff, so it would just fail.

LINK TO COLLECTION TOOL

Strange! I’ve seen a few people mentioning install Rocky and missing dependencies…The few times i’ve installed it so far has gone by smoothly.

Did you boot into the installation media with UEFI or BIOS? did you change any settings, partitioning etc when installing?

I’ll bet you’re on to something with the installation media.

I must have created my bootable drive incorrectly from the ISO, because at the time of installation, I had to pick a network path to a default ISO. (I should have pointed it to the Autodesk ISO, but I was guessing at how to fix it.)

I don’t know which method I used to get to the bootable drive. I’m guessing BIOS, since I F11’ed my way to picking a boot drive. (It’s been years since I’ve been at all versed in this sort of thing, so I’m just cobbling together how to get it all to work.)

Hi all,

We have been using Rufus (Rufus - Create bootable USB drives the easy way) in Windows 10 to create a bootable USB successfully.
Thanks to @Alan suggesting the DD copy method we found Rufus does actually have this option too.
It asks if you want to write USB in ISO mode or DD mode, select DD mode.

Cheers,
Alain @ DVT

Yes, i did! Unfortunately, there were only logs of the dku install and not of the flame install… but after Bob realized i was missing the “expect” Interpreter, and feared there might be more stuff missing somewhere in my Rocky Linux install, i decided to bite the bullet and reinstall everything from scratch. The consensus was that something probably went wrong during RL install due to the additional software i selected to install… So during reinstall i deselected all additional software, took advice from your video on partitioning ( thanks btw !!!) And then everything worked like a charm, except for the 2nd port on my mellanox card which was supposed to give me Internet access. In the end i just used one of the internal rj45 ports instead. Now i have a running flame 2023.0.1 including logik portal, ml timewarp and neat video integration!

1 Like