Flame on Mac Studio is constantly resetting Wacom Pen buttons

Flame 2024 on Mac Studio - flame is constantly resetting the wacom buttons to “button 4” and “button 5” instead of right click and middle click. If I change it back in the Wacom Tablet settings, tab back to flame, they get reset again.

Anyone see this happening?

You have to set both of these to pointer button one. That overrides the OS settings and makes it work in Flame, but your pointer button won’t right click in other apps now.
If there’s a better solution I’d like to know, but that will get it working in Flame.

1 Like

Dam Rufus I just realized you answered me on this question before. I forgot I had asked it :slight_smile:


Haha, Oh well I get to chalk up another solution, cheers!

This might not apply because it was a few years ago. But I ran into this same thing on a Mac trashcan. What fixed it was to quit flame then change the wacom setting. Quit wacom then start flame. When tabbing back and forth the settings never stuck.

1 Like

Yes - It’s the tabbing back and forth that changes the system wacom settings.

How you you enter “POINTER_BUTTON_1” into the interface? The way I usually map a button doesn’t apply to the pen!

In the Keyboard Shortcuts menu, choose the hotkey you want to modify, and click the pointer button on your wacom pen. The Keystroke field should now say “POINTER_BUTTON_1” and you can save it.

Thanks, but it doesn’t work. Clicking the pen button has no effect on the field. What am I missing?

I’m on 2024x1 and it looks like if you click in the hotkey fields it doesn’t stick. But if I click away from the fields… like just above the on screen keyboard, the hotkey will stick. Let me know if that works or what version of flame you are on.