Flame on macOS Big Sur

Anybody running this on a new Mac Pro. Any problems ? thanks -M


I’m been running it in production for the last 2 weeks. No drama. Upgrade did take a few hours of doing it’s thing. Softraid requires public beta if you are running softraid volumes.

And a few misc apps will need updating…cyber duck, Adobe, etc.


@randy. Thanks for the soft raid heads up. That would have freaked me out. I’m upgrading the system disks in the new Mac Pro. requires 2 computers a usb c cable (not thunderbolt 3) ??? and apple configurator2. That’s what I’m doin on Xmas. Wish me luck


Why the 2 computers and extra cables? Running multiple is/versions?

The T whatever security chip is in the internal system drives. Drives themselves are proprietary. Apple just started sellin em a couple months ago.

The T2 isn’t actually in the SSD, it’s on the motherboard. The issue is that the T2 manages and secures the SSDs so you got to go through all these hoops to tell the T2 to let go of the existing drive and initialize the new one. This, in theory, would stop someone from pulling your drive out and accessing the data on another computer but the T2 security has already been compromised - but what hasn’t, at this point?

If you use Promise Pegasus drives, upgrade them to the latest Big Sur firmware in the Promise utility.

FYI, just completed my upgrade from 10.15.7 to Big Sur 11.0.1. Process was seamless. Did take a me a little longer than an hour. I’m running a bunch of SoftRaid disks and those required an upgrade to a SoftRaid 6 public beta, which was simple and took just a few minutes. Looking forward to putting the dual Vega IIs through their paces per @imag4media’s experience. Flame 2021.1 wouldn’t launch, as expected, but a fresh install of 2021.2 was refreshing as there was no need to temporarily disable csrutil.

Also, I can’t remember if this is new or not, but, the ability to copy an older Flame project and create a new one for 2021.2 or convert an older project into a newer version, was quick and painless. Didn’t need to recreate the framestore.


For those interested attached is what one of those expensive stupid little things looks like!


This is the old one 512 GB or 256, can’t remember. Anyone one in the the LA area wanna play with it, it’s theirs. See if you can hack around the T something chip. I upgraded to 2 x 1TB modules. The Apple Configurator / 2 computers / cable thing wasn’t a big deal, but what was, was … I did a clean install of Big Sur, which required doing a install of Catalina in recovery mode. Creating the filesystem, installing the OS and Creating an admin user… then I had to boot back into recovery mode to allow the system to boot of an external drive, then booting off the Big Sur install drive, wiped the disk and new OS installed. That’s some hoops. The only scare was my soft raid volumes wouldn’t mount. I had to roll back to the previous public beta …


pretty smooth all things considering.


My softraid volume on Big Sur is intermittently unmounting and won’t return until a reboot - so it may not be that rolling back to the previous version fixed it. Either way, it looks like people should avoid Big Sur if softraid drives are critical for their work

1 Like

out of curiosity @greg and @randy are you running version B47 or B43 of soft raid.

1 Like

From Catalina / SoftRAID XT 5.8.4 I’ve used:

SoftRAID 6.0.1 b43
SoftRAID 6.0.1 b46
SoftRAID 6.0.1 b47

Haven’t seen any mounting issues. They are my 2nd and 3rd local backups and typically only get mounted via Carbon Copy Cloner, run their nightly clones, then unmount. @greg, what kinda behavior are you seeing?

I’m using b47 - My volume disappears from the Finder and when I open SoftRaid, it sees it but says unmounted and when I tell it to mount, nothing happens. The only way I found to fix it is a restart. It’s very intermittent, though, so downgrading might fix it or it’s just a matter of time until it happens again.

I just got a new computer and it came with Big Sur iMacPro) - all ok until just now when I went to do the update and now it’s stuck in a reboot loop?? Anyone else have this??

1 Like

If it came with Big Sur is it a small point release update that you are doing?

have you tried to reboot with apple-r on the keyboard and to do a reinstall of the OS ? Seems like this is a known issue, and that is the fix. PITA. Does you Mac have FileVault enabled ?

Yes its a point release - and yes that’s what I am currently trying…and no I dont think firevault was enabled…I was just googling and so I did the recovery mode and chose the option to reinstall OS - it’s in the process now of reinstalling OS… fingers crossed this works! Just not sure if I have to do any disk repairs as the boards I researched have different ideas,…

Ok so…PITA is right! I reinstalled OS - nope - reboot black hole. I then did another recovery mode - this time did disk utility and then CHOSE and unlocked the HD as the startup disk…nope - reboot black hole - so I unplugged my Promise raid (as I was reading that the issue is that the computer didnt know what drive to use as the restart drive - so that worked - even thought I had chosen the HD as startup - so does this mean that I cant have my promise raid connected on restart?? Even though I specifically chose the HD as the startup drive?? UGH

I don’t know if this applies to you, but I just jumped through these hoops yesterday. If you’re booting, and you can the use your promise, I wouldn’t push it too far. But this saved my bacon yesterday. I needed it to boot off external drive, but maybe there’s something in there that can help solve the mystery.

Use Startup Security Utility to set secure boot options

Secure boot options are available only on Mac computers with the Apple T2 Security Chip.

After you restart your Mac, changes to the secure boot option take effect.

  1. In the Recovery app, choose Utilities > Startup Security Utility.
  2. Enter an administrator username and password.
  3. In the Secure Boot pane, choose one of the following security options:
  • Full Security: Ensures that only your current OS, or signed operating system software currently trusted by Apple, can run. This mode requires a network connection at software installation time.
  • Medium Security: Allows any version of signed operating system software ever trusted by Apple to run.
  • No Security: Does not enforce any requirements on the bootable operating system.
  1. In the Allowed Boot Media pane, choose one of the following boot options:
  • Disallow booting from external or removable media: Restricts the ability to boot from any device not protected by the T2, such as USB and Thunderbolt drives or internally connected PCIe or SATA drives.
  • Allow booting from external or removable media: Does not restrict the ability to boot from any devices.
  1. Choose Startup Security Utility > Quit Startup Security Utility.

Oh and @SamE has some experience with the promise stuff on a pretty granular level. Maybe he’s seen this. He has some advice up a few posts in this thread.