Gmask defaults - 2022

I said I was going to read the manual next time, and I did. It’s not really helping in this case. All I want is to have autotangents turned on when I add a gmask in my gmask tracer. I believed I last solved this problem 2 years ago by creating a gmask with autotangents turned on, then Save>Default did the trick. It does not appear to work this time around. The new “Save Default Setup” dialog does not seem to solve my issue either. Is this broken, or am I missing something?

Preferences > Action > GMask Vertices > Auto Tangents

I’m noticing a trend.

Mmmmmn not so much. I can select Auto Tangents in the preferences, but when I create a gmask, it is not correct. AND when I go back to preferences, Auto Tangents is turned off. I have confirmed that I can turn it on, exit the application and when I return, it is still on, but once I make a gmask, it turns off.

OK, so I have this figured out. There seems to be an issue with a conflict between the Preferences > Action > GMask Vertices > Auto Tangents and the Gmask > Save > Default. Once I cleared out all my old defaults from User>Me>masks>pref, all worked as expected. I did notice one oddity, however, on this long and frustrating journey: if you save the default setup using the new Objects & Maps > Default Setup dialog using a gmask tracer from the tool tab, it seems to hardwire in the resolution, whereas if done in batch, it does not. And for the record, the search function in the manual sucks. And while I’m at it, having preferences under a tab called Action which are not neccessarily action related is less than intuitive. Perhaps in a future version one might consider renaming it Action & Masks.

And thank you for your patience, Philippe.