Hardware accumulator can't copy region

Anyone seen this before?
It’s stopping my render after 8 frames.

1 Like

Hiya Paul, would you please provide more information?

What Render? Timeline? Batch? BFX? What is your source material? How many frames? What hardware are you using? What software are you using? Any motion vectors? Any Camera Analysis? Any Matchbox shaders? Any plugins?

I’ve had similar things happen when one of the sources had a corrupt frame.

1 Like

It’s a Batch render, source material is EXR, with a QT element, it stops at frame 8 of 40.
Dell precision 7920, quadro RTX 6000, 128G RAM.
Flame 2022.2, one action node with motion vectors, one matchbox, CROK Renoise.

1 Like

Agreed. Check that the file sizes of each EXR make sense. Likely frame 8 is corrupt per @ytf .

If you have a bunch, slip half of your source clip 7 frames towards heads. If it crashes on frame 1, one of your sources in that slipped is corrupt. If its not, slip the other half. Rinse and repeat til you nail the clip that has a bogus frame.

I would contend that there is a corruption on frame 9.

Was there ever a solution found for this? I’m getting the same problem now. I’m finding that the problem is coming from my action node.

I had the same problem today using action and color correction. I closed the flame and opened it again. rendered the new version, the problem stops. :man_shrugging:

I tried that. I had to dump my action and rebuild it and now it’s working.

I didnt have any corruption, but it would always render on the second attempt.

This error happened to me again, when I’m trying to create a second output matte in action. This layer has motion vector and motion blur, but how this is a simple finger roto matte, I connect direct, and the error disappears.

the layer action connects in this motion blur result.

Hey everyone, I had this “Hardware accumulator can’t copy region” issue today. After rebuilding the batch a couple different ways. My workaround was to create a BFX Pre-Render of the Action outputs, then continue finishing the comp from the BFX rendered clips.

Hope this helps someone.

1 Like

Having a lot of issues with this bug/error lately, what version were you guys running? I’m on 2022.2

I’m now on 2022.3 and, touch wood, haven’t seen it since.

1 Like

Still having this issue in 2022.3
Has anyone found a solution to this problem?

Someone mentioned this elsewhere (sorry, whoever you are) but switching a problematic action from live preview to 3D (or vice versa) and framing back and forth will fix it for me for a while. Pre-renders of any paint nodes also help, but I kinda hate pre-renders…

Anchor processing error or whatever it’s called (regarding paint nodes) makes me say words I hope my mother never hears almost daily. F1F4F1F4. We should just probably prerender paint always :frowning:

1 Like

I run into it a lot and the live preview toggle/frame forward thing usually works. I had like 15 paint nodes pre-rendered and managed to reconnect a fair number of them and still function. But yeah, between this and the “micro freezes” there has been some salty language thrown about lately.

1 Like

Thanks Kirk.
I tried what you suggested but it didn’t help, the render always fails with the ‘Hardware accumulator can’t copy region’ shell output.
I stripped down a problematic batch, no paint node, the source is a single 4k bars generator (bt1886), 1 action with 3 layers, 3 gmasks, 3 blur nodes, 1 cc, all outside of action.
Motion blur turned on in action. If I turn the MB off it renders, but it fails when it’s on.
Beside from that MB thing, troubleshooting is almost impossible due to the random failing or passing outcomes.
I turn the bypass on/of on various nodes and sometimes it renders, sometimes it doesn’t.
In the exact same state, it can fail multiple times, then pass, or the opposite.

1 Like

I was expecting that 2022.3 would fix it. But sadly still UI glitch renders from Action :frowning: