Has exporting files with an embedded alpha vanished in 2023?

Hi fellow flamers.
First post and hopefully it’s a simple one to solve!
Since 2016 I have always been able to export a BFX or text effect with its alpha to either a DPX or EXR just by highlighting ‘Include Alpha’ on the Mediahub export page.
Have just gone to do the same in 2023.3.2 and it does not appear to work anymore. I’ve tried everything I can think off and whatever I do there is still no alpha channel. I don’t need the option of Multi-channel as I just need to export either a BFX text effect with alpha or a Text Effect with alpha. Have tried TIFF, DPX and EXR and they are all the same - just RGB and no alpha. BFX have Comp off and inside have a matte output from the action into the batch output (BFXa). The Text Effects are set to RGBA. Jumped back into 2022 and did the same effect and it works fine.
These are just simple subtitles which I now need to export for a resolve grade but what I thought was going to be a simple export is beginning to make me think I should do them in resolve - please save me from the resolve title tool!



Have you tried exporting in the Foreground?
I seem to remember this being a bb export bug. I think maybe…

Hi Ben,
Thanks for the reply. Yep I always export in the foreground as background usually takes ages.
I have found a way of getting the alpha from the BFX onto an EXR seq which is to add a write node in the BFX and render out that. However I need to have the record sequence timecode on the files, and the write node doesn’t seem to give that option (apart from manually entering it, which as there will be a lot, I don’t really want to have to do!)

The search for an answer continues!


I have no issue with the BFX on v2024. RGBA Text only works if I add a BFX adjustment layer and connect the matte to the BFX matte channel.

I checklist this in 2024 recently with success:

  • connect the alpha result of your bfx comp, to the alpha input of bfx node output.

  • If your timeline has only one layer with your bfx layer, add an empty layer below.

  • keep sure “comp” button is disable

  • Important: maybe a known bug, disable “export in to out markers” or you will have a white alpha.


Hi all
Thanks for all the suggestions. Unfortunately none of these have solved the problem in 2023.3.2 and I’m still at a loss as to why such a simple export method has now disappeared and not just with text - I did a screen replace style BFX set up with a g-mask in an action which I’ve been doing for years and I can’t export that with an alpha either, so its either back to 2022 or resolve’s title tool…



I know it’s a lot of hassle, but to keep it Flame you could try to:

  1. Render your front and matte as separate clips
  2. Use Tools / Utilities / Create Matte Container and create a clip with matte container
  3. Make sure you have turned Comp button ON on the timeline
  4. Export ProRes4444 with alpha