Export Quicktime with alpha

A note to myself…

This is the way it works:

Timeline with a BFX, make sure you have an alpha connected to the output node as well as the “Front”. Exit BFX.

On the timeline turn on the “Comp” button. Now export the clip.

Choose “movie” and the type as Final Cut APR 4444.



When I do it I turn comp off. If I leave it on I just export with a full frame of white as the alpha.


Did you know you can use bookmarks to save this for yourself? Forum bookmarks, not browser bookmarks.

1 Like

bookmarking this response to remember about bookmarks.



Wait I am trying to do this and if I hit comp the bg is black but I get an alpha, how do I not black out my BG but export the embedded alpha?

1 Like

Turn comp off.

yea I am trying that but when I do that all I get is a white frame not the alpha that I am putting into the matte in my bfx, wonder if some bug exists because I did a simple text with a color and a mask and it worked as intended but when I do it with my comp and alpha out of action I get a white frame, super weird. I was trying some tests but can’t figure it out super simple comp, FG key with BG matte painting alpha spit out of action into bfx, can see the bfx alpha if i f4 it but when I export it just white, if I do the same export with a color frame and mask same export setting I get the alpha.


Or, this…?

So I am doing this through BFX not batch or matte container, the first shot is the test (color frame) and totally works alpha of mask is exported the next setup is basically the same but it is more complex but only outputs a white frame even though I see the matte in the BFX f4 toggle

ps I placed that gmask on the action output just to see if OFX was doing anything but it still reads, if I plug it into a resize I still see the alpha but once I export the alpha is just white.

something to do with the clip dragged the setup over to a color frame and it works as intended, the mystery continues, this also makes me realize it would really nice to see the alpha that is being exported or attached to a clip like shift R, or shift G or what should be shift A for alpha

I forgot I asked this on the flame forum a bit ago, I totally forgot and thought it was a few versions ago, I guess a known issue.

This is a known limitation documented in Flame Family 2021 Release notes (search for FLME-51172 to see the workaround)


For anyone looking for the quick answer, you have to flush the render then export, worked for me.

@randy just out of curiosity since I got to export correctly out of flame, it looks totally correct and behaves correctly in flame, however when I open it in the quicktime player its the front over black clearly negating what the alpha is , do you know of a setting in quicktime to view these files correctly?

Has anyone experienced this no longer working with Flame 2023.0.1?

Because I can’t get anything to work. All solid mattes.

been doing a few of these lately…

i have these screengrabs done using r3d footage in an Aces project, outputting to rec709.
On the top video track there is a Colour Management node with a View Transform, and an animated cg pass on the lower track.
To make the gfx passes with alphas, i have stripped out all the underlying video as this will usually give you a full white frame of matte.
The graphic has COMP ON. The CM Node has COMP OFF. To view the Matte, select Viewing Settings from the Options menu whilst in Player mode, click the button labelled View RGB and it switches to View Matte so you can see what the matte looks like.

If you switch between comp on & off on the CM Node the matte channel changes, so you’ll need to decide how you want the matte to be saved.

these screengrabs should show what i’m doing.
These then get exported using Prores 4444 with export Alpha selected.

hope that helps


Yeah it’s really strange that looks just like my timeline. Matte looks good on the timeline, I can drop it wherever and have it work. It’s only when I try and export it doesn’t.

I don’t want to say I’ve done this a million times but maybe a hundred? Never had an issue before, that’s why I was wondering if it was some sort of a bug.

I ended up just taking the entire timeline, dropping it in batch and using a Write File node to do PNG with alpha, worked fine there.

just did it in 2023.1 - BUT didnt like my batch made MULTI channel render - got it to work using the container method randy shows BUT had to have contain only checked NOT Contain and comp - hope this helps

I just tried exporting a clip with alpha and have fallen into the same problem. I do have a container with a source matte:

And on the sequence I can see the alpha cutting the fill.
I then turn off comp and export using the prores 4444 preset.

I just see a flat white alpha.

What am I doing wrong?