I Bricked a Z840

Machine was working fine until I turned UEFI on and Legacy Boot off in BIOS. Now during POST I get six beeps and nothing on screen.

According to the guide, that means “Pre-video graphics error” so I’ve tried 4 different video cards: M6000, Quadro 6000, Radeon 5850, and GTX 1060.
I’ve tried resetting CMOS and pulling the battery.
I’ve tried the Crisis Recovery Jumper - the thumb drive blinks, but I still get the beeps on restart.

If anyone wants to dump their Z840 BIOS for me, or has any other suggestions for how to reset the BIOS or unscrew myself, I’d be very appreciative.

This is a deprecated non-production machine, so nothing of serious value has been lost. I 100% blame @ALan for my current predicament.


1 Like

Doesn’t seem to fit your scenario, but a few months ago I wasted a few hours with those pre-graphics beep errors. Like you swapped GPUs, reset board via jumper, etc.

Turned out to be very basic pilot error. Modern BIOS need to have a monitor connected to boot and get display EID.

On my system I have a physical display port switch to mux the monitor with another system. The switch was set to the other system, and the booting system failed to get a EID.

Maybe try different cable, onboard GPU if it has one, etc.

i have zero knowledge to offer- but if its a “pre-video graphics error” doesn’t that mean the fault is before it gets to the video card? So swapping out cards shouldn’t make a difference?

I think in this context it means error before error information can be displayed on screen as no functioning screen is available yet.

Some boards have LED number displays that can display an error code instead of just the beep pattern.

My experience with the lack of monitor was that the machine booted up just fine, but with no graphics card. I could log into it remotely with no issues.

I think that depends on the board. I should have clarified that my case was not an HP Z840, but an Asus board. As soon as I flipped the switch to connect the monitor everything was fine.

I had walk into work on a cold rainy Saturday night in winter to turn my monitor on once. It wasn’t a Z840 either. I don’t turn my monitor of any more, ever.

1 Like

I do recall the onyx wouldn’t boot without a monitor attached.

You could erase and reflash your bios using a clip programmer, its quite easy to use. you just need to know where the bios chip is located and fix the clip there.
It seems the gpu you are using does not work well with legacy boot, maybe you need to set your boot to DUAL instead of just legacy or uefi only. I had this issue with a rtx 3090.

1 Like

When you enabled UEFI mode, did you also switch “Option ROM Policy” to “All UEFI Except Video” ? “Secure Boot” should have already been disabled.

If you didn’t switch that then it is expecting a graphics card that is UEFI compliant so you can get into your BIOS and change that setting.

However, the GTX 1060 should have worked; it is supposed to have UEFI support. If a UEFI supported card doesn’t work and flashing the BIOS doesn’t work, it may be the system board which is a bummer.

I’m certain Secure Boot was disabled; I did not touch the Option ROM policy setting, but I don’t recall what it was set to.

I agree with your assessment - The M6000 doesn’t support UEFI, but the 1060 does, so I don’t know why that card didn’t work.

While this suggestion may not solve the issue you are facing, it may be worth a few minutes to test. I would suggest trying this again, but be sure to have the power cable disconnected before starting. Then disconnect/unplug all carda and devices, wacom, aja, etc, leaving the video card in. Depress the power button down for a full 30 seconds, then hold the cmos reset for 10 seconds.

After completing the above, connect the display, turn the display on. Then plug-in workstation power, :crossed_fingers:if applicable, then boot.


Didn’t Crisis Recovery Jumper work ? I had a fatal bios issue in my z820 after plug (or unplug) a graphic card (or an lsi raid card, I can’t remember). After try all methods to clear cmos / reset bios I was about to throw away the machine, I found a post about the Crisis Recovery Jumper (completely undocumented method at that time) and it worked for me.
Here you have more recent info with an specifical part for 840 models.

1 Like

I have a spare Z840 motherboard in stock. Havent tested it but can test if needed. Bought years ago to swap in case things go south in the middle of a job. been in the box since then

I got the machine back up.
Last thing I tried was the HP PC Hardware Diagnostics 4-In-1 USB Key, but I can’t tell if that worked or if my last attempt with the Crisis Recovery Jumper was successful.

So now it boots, but I’m still stuck at a black screen after installing the latest DKU.

1 Like

Have you looked at the GRUB entry I sent you?


Forward momentum, well done. I would get it on the network so you have SSH as a fallback. Then check if nvidia modules are loaded or run nvidia-smi. Since you are not using a supported card, you may have luck manually installing a video driver.

1 Like