Rocky install on Z8 issues

Looking for some advice on installing Rocky 8.5. We’ve got a HP Z8 G4 that won’t boot from bootable USBs and so for CentOS installs I’ve made bootable DVDs that have worked fine. Problem is, the Rocky 8.5 ISO is nearly 10GB and too big to fit on a DVD. Has anyone had any joy installing Rocky a different way, or advice on getting a Z8 to boot from USB?

1 Like

Yikes. I haven’t heard anyone installing from DVD in about a decade. Have you promoted the USB device to the top most device in the bios for boot up?

1 Like

Try this link

1 Like

Thanks Randy but I have already set the BIOS up with USB at the top and Legacy Boot enabled. The external technical support guys we sometimes work with tell me that they’ve had lots of troubles specifically with the Z8 G4s booting from USB and have also had to resort to DVD so I think there’s a core issue somewhere. There isn’t even a single BIOS update I can find for it anywhere. Hence why I’m on the hunt for alternative installation means.

Hmm. That’s such a common machine I figured if that was a thing I’d have heard of it by now.

@andymilkis is a Rocky and Z8 owner and I don’t believe he’s had any issues.

How are you burning the iso to usb?

Burning with BalenaEtcher on my Mac

We have upgraded a lot of HP (Z840/Z8), Lenovo, Dell, etc and had no issue. Most issues are related to DVD not being correctly closed.

I would recommend skipping DVD based OS installation and use either dd command OR Rufus (macOS & Windows). Have a look here:

rufus (Rufus - Create bootable USB drives the easy way)

You could also use

I did also trying burning with dd but had same result. Will give Rufus a go.

A quick poll of the Sysadmin Slack returned no known issues with HPs booting from usb. Triple check that boot mode is set to UEFI, The front and rear USB devices aren’t disabled in the bios, and try some new flash drives. Typically the cheapo Sandisks work for me. And last thing try a USB 2.0 or 3.0 port. Maybe your thumb drive is one of the other.

Let us know!

The only issue I had with dd is when I did not use the USB stick volume mount point but the first partition (i.e. if the USB stick is mounted as /dev/sdi, you need to use /dev/sdi and not /dev/sdi).

I may be missing something big, which is definitely not a foreign experience for me, but Z8s and HPs in general from the 9400 days to the Z800/820/840 are likely the single most popular platform for Flame since the SGI/Onyx days. Most of the long time Flame sysadmins have been working on them for 15 years or so. They are definitely known quantities. And based on the responses I got on the Sysadmin Slack, it ought not to be an issue. Definitely dig a bit so that you know how to do it, as there are a handful of us recently here that are artists posting as sysadmins trying to build their own Linux Flame for the first time @andymilkis, @Jason_Kalinoski, @Brooks and have figured it out.

Hang in there. It’s frustrating for sure but the results are worth it!

Well you were right; I persevered and it has booted from a Rocky USB! Unfortunately I changed three variables at once (new USB stick, rear USB port and used Rufus on a Windows machine) so not sure which was ultimately the catalyst. Normally I’d be desperate to know but after spending all week fighting a new CentOS 7.6 install I’m just happy to have the chance to tackle Rocky instead! Appreciate your invaluable help @randy and @Slabrie

1 Like

Emma Stone Snl GIF by Saturday Night Live

Thanks for the update Bens!
As they say : Corey Hart - Never Surrender (Official Music Video) - YouTube

Ah. $5 says there is a security setting in the BIOS somewhere the disables access to the USB slots on the front of the device.

1 Like

I promise you I checked that, and I have the proof!

Do you want to wire me that $5 or…

Doh! I’ll send you $5, but only if you double check one more thing. Is there a setting in security that disables booting from a front usb?

Apple Cash? :slight_smile:

Dont Give Up Hang In There GIF by Holly Logan

I installed 8.5 on my z8/RTX A6000 this weekend, and let’s just say it lived up to the name “Rocky”

Things were pretty smooth with the OS (aside from not knowing the little cog next to the Sign in Button must be set to the right version of X11 otherwise you log into a black screen) until I installed the DKU and then the boot process started to signalterm before completing leaving me dead in the water and resorting to single user mode to figure it all out.

Was able to eventually get everything up and running but if anyone has any issues know that you’re not alone, and I can let you know what worked for me.

Are you guys using the ADSK version of Rocky? I just can’t understand at all how you have all these issues.