Launch Flame on Mac from a Terminal

Launching Flame from Applications or the Dock means you are missing out on potentially vital information in the App Console. If you need to troubleshoot error messages or odd behavior, or if you are writing Python scripts then this tip is for you.

This example uses Mac Catalina 10.15.5 and in my particular case I am using a Z shell, or ZSH. You may be using Bash. l to create an alias to launch Flame 2021.1. Be sure to substitute your version of Flame and whether or not you are using Bash or Z.

Which Shell are you using? Open a Terminal. If it looks like this you are using Z shell.

If you are using Bash, it’ll say “Bash.”

Z Shell instructions…

  1. Launch a Terminal.
  2. Enter sudo nano ~/.zshrc
  3. Add this line…

alias flame=’/opt/Autodesk/flame_2021.1/bin/startApplication’

  1. Control-O to enter.
  2. Hit Enter.
  3. Close the Terminal.
  4. Open a new Terminal.
  5. Type Flame.
  6. Voila!

Bash Instructions…

  1. Launch a Terminal.
  2. Enter sudo nano ~/.bash_profile
  3. Add this line…

alias flame=’/opt/Autodesk/flame_2021.1/bin/startApplication’

  1. Control-O to enter.
  2. Hit Enter.
  3. Close the Terminal.
  4. Open a new Terminal.
  5. Type Flame.
  6. Voila!
13 Likes

That is really slick! For some reason it isn’t working for me though. Everything looks the same following the video and my flame version is correct. I get “-bash: flame: command not found” after typing in “flame” or “Flame”.

I have been using “/opt/Autodesk/flame_2021.1/bin/flame.app/Contents/MacOS/startApp” and that works but definitely not as cool as just typing in flame.

Hmm.

This is my command. alias flame=’/opt/Autodesk/flame_2021.1/bin/startApplication’

Just tested again. Be sure to close the terminal after you hit Control O in nano and open a new terminal. What’s your OS version?

When you launch a terminal, what does it look like? Does it definitely say zsh or does it say bsh?

1 Like

Hey Dave, did you sort this out? It looks like your path isn’t the same as your alias.

OS version is Catalina 10.15.6. When opening the new terminal it says “The default interactive shell is now zsh. To update your account to use zsh, please run chsh -s /bin/zsh.”

Ah…so looks like you were using Bash! It’s a different interactive shell. So, do everything the same as I did in the video, but, instead of modifying the ~/.zshrc file, edit the ~/.bash_profile

1 Like

I have a different way of getting the correct path for the “…/startApplication” command.

  • If your icon lives on the dock, click and hold on the icon until the menu pops up
  • Select Options/Show in Finder. This will open the folder where the application lives
  • Right click and Show contents
  • Goto Contents->MacOS
  • Open your favorite terminal on the side
  • Now click and drag the startApplication file to the terminal window
  • Your correct path should be there and when you press enter Flame will start
  • I am lazy and I keep this terminal always open
3 Likes

1000% Yes on this tip!

You using 2021.1 yeah? the path will be relevant based on your version installed.

1 Like

I too had the same problem of it not working until I realised that I had to remove the quotes in the path.

Another option: StreamDeck + keyboard Maestro

2 Likes

Nice. What’s your folder date button do?

creates a folder with date_time

1 Like

Ooh! Interesting. That’s on my list of projects. Is that a python script? Or what’s generating the dated folder?

Keyboard Maestro, but I think there’s many ways: Automator, or Applescript.

Great stuff here guys, thanks for sharing! Here’s my version of the launching Flame using terminal and mac shortcuts (Automator & AppleScripts). There’s a ReadMe file that explains how to “install” and use this stuff, but post any questions.

4 Likes

And here’s a python script that creates dated or timestamped system folders through the MediaHub:

2021.2 & Higher only.

4 Likes

It worked for me after adding the volume to the path - like this:
alias flame="/Volumes/Macintosh\ SSD/opt/Autodesk/flame_2021.1/bin/startApplication"

Does anyone know how to change the Mac terminal to use esc for autocomplete instead of the default tab key?

1 Like

hmmm…might need some lateral thinking. what problem are you trying to solve?