No real-time playback on Linux flame 2023.3

Hi there.
I’ve got a strange thing happening these days.
I work on a very nice Linux box on flame 2023.3.
Machine works perfectly and is very fast in renders and all but…

I can’t have a real-time playback of any clip in the timeline…
My shots are 4K but my timeline is 1920x1080 10bits.
Everything is rendered and I can’t play it smoothly.
Even RAM play doesn’t work as expected.

Anything I should try to fix that?
The built in test disks tool shows 649.88 fps and 881,68MB/s for the framestore…(read speed)
Write speed is much lower (around 220MB/s)


Os is Rocky 8.5,
192gB ram
RTX 5000 GPU with 24GB and driver version is : 460.91.03

Those read and write speeds don’t sound like a nice Linux box.

Please provide more details. What kind of storage? NVMe? Spinning disks? RAID? Filesystem? Chassis? Is this a Dell? HP? What model number?

It’s a Z8 HP station with an internal XFS RAID of 8 Sata SSDs. (14GB capacity)
It’s about 55% full

Have you got any previous versions of flame installed?
If so, do you get playback there.

Nope. It’s the only version installed.

I’ve just tried a disk speed test on my box and I get 40fps / 1906Mbps on 2023.3, but 115fps / 3817Mbps on 2022.3.1
So maybe there is an issue with 2023.

Yes maybe there’s something .
But still, I have much lower numbers than yours.

And secondly, 880 MB/s should still be enough to play a HD 10bits timeline shouldn’t it?
And anyway, 8 still have the same issue in RAM play… :frowning:

Hello philobedo!

I would recommend opening a ticket with our Support them so an agent could help you investigate the issue since this is far from a normal behavior.

-is this a new issue OR this is a new configuration?
-if you start nvidia-settings (from a shell), what do you see in the Refresh Rate section of the monitor?

Are you using a Display port cable?

Actually, I’m not on the machine anymore. It was a quite short mission in that facility….

As far as I know, it was not a new configuration but flame version has been updated from 2022.3 to 2023.3 I guess. I have to say that I had worked on it before the update and it was working perfectly fine.

Maybe it’s a config thing… I can’t have a look at the refresh rate now, sorry I didn’t have a look before.

I just strongly advised them to contact the support to have that fixed but I can’t do more now…

I’m pretty sure it was a HDMI cable from AJA to video display,

I think theres definitely something odd going on here. I’ve just done a speed test on my mac at home and get the same disparity between 2022 and 2023.
2022.3.1 gives 53fps, 2511Mbps, whereas 2023.3 gives 17fps, 830Mbps.

Is the cache format compressed?

2022.3.2, 2023.3.2 and 2024.0.2 service packs hopefully fix this issue. @Slabrie disclosed it on Logik Live today.

I doubt we are talking about the same issue as what has been fixed in the latest service packs we have made available last week BUT it could be a good idea to give them a try. But since you are no more on the system I guess it will be difficult to pin point the issue.

@paul_round please make sure you are using the same cache format between versions since there are no apparent changes made to our products that could have affected cache performance in the versions you are comparing.

Same cache format on my linux box and pretty sure it would be the same on the mac.
when I get time I’ll install the updates and check again.

I’ve just installed 2023.3.2, theres a definite improvement but it’s still slower than 2022.

goto 2024.1. It is a great release, and lots of little quirks and annoyance have gone away. Also, are you at least on RockyLinux 8.5? If so, do the easyUpgrade to 8.7

Still on Centos 7.6

Time to let it go.