PFTrack - new version to Flame?

Hey all,

Is anyone using the latest version of PFTrack? They changed a bunch of stuff for no apparent reason, and maybe broke some things in the process. The old standby scene orientation axes don’t appear to orient the scene around the origin anymore, but more importantly even though I’ve set the clip framerate to 23.98, FBXs are coming into Flame with what looks like the framerate set wrong. I’m just using it for an anamorphic screen comp, so I was able to drag the anim curves to the correct length using tracks in Flame’s animation editor, but this feels trash. Anyone else seen this? Did I miss a new setting? TIA!

1 Like

It’s likely a pebkac problem, I’ve been using it on an off the last year without troubles… is the Flame project setup at 23.98?

I will admit the new project manager took some getting used to after being away from it for a few years, so, thoughts and prayers.

Yep. My Flame projects haven’t been anything other than 23.98 in like…a decade. PEBKAC is still enitrely possible, though.

I have the current PF track, been using it since its release and haven’t really had any problems, yea project management was the big change , well along with other things, but so far round tripping into and out of flame has been good . I just use Orient Camera under utilities , switch that to rotation and camera should be aligned. Frame rate hasn’t been an issue so not sure what’s happening there

1 Like

Thanks, man. I’ve always used Orient Camera → Draw Axes to line up my scene. Upon further digging it still works, but you have to switch to another edit mode after you do it and hit “set origin” again.

How’re you exporting your scene to Flame? I tried both Autodesk FBX 2011 and 2019, and had the framerate issue in both cases.

I only do io/ scene export. I am confused on the frame rate thing as that shouldn’t make a difference as long as the length of the clip is correct, export doesn’t have a frame rate setting and I tried setting the clip at 25 and 24 and 2398 and all are the same since the clip is 72 frames long it shouldn’t adjust any tracking info since the length is the length, I just leave scene scale set to 1 and typically when importing into flame set size to either 10 or 100 depending on the scale of the world, hope this helps. Oh and I have the export set as ADSK 2019 FBX

Hi all,

I figured out how to fix my problem. I had to turn off “Keep FBX Frame Rate” in the FBX import options on the Flame side. I don’t remember ever having to touch this in the past. Was it off by default in previous versions of Flame? Is the new PFTrack writing incorrect framerate data into its FBX headers? Who knows! I turned off “Keep FBX Frame Rate,” and now everything is hunky dory!