Question - Create Rule not working

Hey all,

Thanks for your help in advance.

Archive from out of house, files are not cached, have all the folders, path is wrong. First time this is an issue for me, did some leg work and found the “rules” option in storage. Source Path, Destination Path. Did the thing, it is not working. Tried restarting flame (which should not be needed) - still nothing. Am I missing something?

Thanks again.


Do your rules BEFORE you restore archive.

Trying now.

: )

Nope, (restoring archive after rules are set - which by the way is NOT how Grant teaches in the video above) no luck, still unlinked all around.

I did also “phone a friend” and a third archive restore with “Convert to Local Path” selected (as opposed to “Use Archived Path” - seems to have resolved the issue but I am still missing the countdown slate audio of all things.

I am working in 2021.2 to match client machine and the Grant video is from 2018. Will rock on from here for now I guess.


It’s broken. As you found out you need to convert to local path. Annoying to say the least but it’s one on the workarounds. The other is that while path translation doesn’t seem to work by itself, it will obey the translated paths in a relink scenario so you can just unlink clips and link them back using the path option. This is also a hassle but will help in a pinch.


Hi there C,

Yeah, the relinking thing was an option but there were so many bits I was hoping “create rule” was real. Local path kicked major butt though. Good times.

Thanks for the info about the broken! Great to know.

: )

1 Like

Thanks all. It does seem to work here. Not as Grants video but with the workaround.

Archive soft linked with original path. On destination machine create path translate rule as per Grants video. Restore archive with convert to local path.

Hi All,

Just to chime in here since I have been mentioned multiple times :blush:

I also recently encountered this last month and I have been discussing it with the team.

Firstly, the Linked Archive Options are to be used when RESTORING an archive and not during its creation. If you look at the tooltip, it states what wiretap gateway will be used as part of the restore.

Secondly, the correct operation in dealing with linked media is that the Linked Archive Options should be defaulting to “Convert to Local Path” and not “Use Archive Path”. This makes sense in my mind because if you are restoring on any machine, the paths should follow the local path structure via the local wiretap gateway. If it is the same machine, the path structure should not change. I stand corrected if I am wrong but that was my understanding.

If your file paths are mirrored on your systems and you restore the archive, the linked media should be found immediately and appear in the project.

If your file paths are different (for example in the case of restoring a Mac archive on a Linux system), the file path translation “rules” should be used to translate the file path and your media should reappear without having to reboot Flame.

I wouldn’t consider this as broken or a workaround because there are a lot of options, and we need to get to a point where the default settings meet most of your needs. I need to review my video around this as lots has changed and progressed since the recording.

Hope this helps!




Grant is right: the default option is set for studios sharing archives between workstations in the same workgroup. If you do not have the same mountpoints on all workstation, then media will be read from the original Wiretap Gateway. This is a no config environment.

if you get Archives from other facilities, you will need to define a Path Translation AND you need to make sure to set the option to Convert To Local Path.

Many got bitten by this settings, including myself.


Hi. I’m having a similar issue related to this. Not moving archives but just exchanging batches between two systems. At its core iMacA has its media on its desktop and iMacB has same media on its desktop. When passing a batch from iMacA to iMacB, to have the media relink using rules i would just expect to have a rule. source : /Users/iMacA/Desktop/ destination: /Users/iMacB/Desktop/ but this dosent work. is there a work around for this? There is no convert to local path when just importing a batches

I believe you are required to archive for path translation to take effect.