Rebuilding an RnD batch using older SapphireSparks

I’ve taken over a big RnD batch that utilizes Sapphire Sparks that are older, and having the latest sparks on my machine is not allowing those original s_sparks to be viewable, the text remains red and there is no result.

Any way around this? Can I install an older version? I have no idea what version they are…


I would thing that the error would get logged in the terminal you use to launch flame and that would include the version number. Or you may find the version info buried in the ascii file for the batch. You also might find the actual set-up info in there as well. If you can’t open the sparks by loading older versions, you might be able to load the new versions and enter the info by hand, or carefully cut and paste in the ascii files.

Did you have any luck with this? I have the exact same problem with having an unknown version of Sapphire Sparks in an old batch. I tried viewing the error logs in my iMac’s Console while I loaded the batch, but I couldn’t see any clues. I also tried installing 2019, Sapphire 10 & Sapphire 11, but my pesky Sapphire node is still red. Any thoughts?

The latest version of sapphire OFX comes with a Python script that will replace the sparks with the corresponding OFX. Just right click on the spark and select the script.


That’s good info… Thanks man.