Sapphire lens flare occlusion

Hello All, Any Flame Sapphire OFX users around? I’m trying to occlude a lens flare by piping a matte into the occlusion input. The lens flare just goes black. I checked the help file. It lists a bunch of occlusion parameters that look like exactly what I need. The thing is, these parameters are nowhere to be found inside the OFX node. Very strange indeed. Do you know where they might be hiding? Or how you ‘activate’ the occlusion. Cheers! Grant

1 Like

I’m not sure if these are the things you’re looking for but on page 3 there are some parameters

It works but can be fidly. Long shot. Clamp the matte input?

Thanks Peter & Randy.

Yes Peter, those occlusion controls are exactly what I’m looking for. It’s very weird, but they are not showing up for me. I just have Mocha parameters on page 3

Are you on OFX? My Flame is 2021.1.1


Hi Grant,

I’m on Flame 2021.2, Sapphire 2021 OFX

I now see the situation you’re seeing.
What appears to work is based on selection order:

  1. pull out an OFX, select Lens Flare
  2. attach Matte 2 (Occlusion Alpha)
  3. attach back (occlusion)
    4 attach front

When I tried a different order, the Page 3 Occlusion menu doesn’t appear.

I also tried in LensFlareAutoTrack and see the same pattern.

I think some OFX don’t always give the results we’d expect like in Sparks until we add extra input layers, and it appears to be even based on selection order as well.

Hello Peter

Thank you for testing this. You are right!

You simply have to pipe in the occlusion first and it works.

I spoke to Brian at Boris - it’s a bug.