Sequential file name import issue

I’ve been given some files that have been through an NR process and the software has just tagged NR to the end of the file names, after the sequential file number

eg

orig files were “name_####.exr”

nr files are “name_####_NR.exr”

Flame now sees these as individual files, not as sequences. Any way to force flame to see them sequentially? Or can someone suggest a good (easy) linux renamer utility?

tia

Des

Hi, have you tried shutter encoder Shutter Encoder encoding|converting video FREE PC|Mac . It’s a nice tool to have and have a renamer utility build in.

Hi Francesco,
Thanks, but I’m remoting onto a linux system …mac and pc are not an option.
D

If using python scripts are an option, I could probably modify one of mine to do a find and replace in the mediaHub. Let me know if that would be helpful.

Hi John, that definitely sounds interesting.
Ideally you would have find / replace plus renumbering with padding options.

I’ve found linux utility ‘metamorphose’ which is fully featured, but the interface is terrible as it doesnt scale properly. I think its quite old…

Des

Hi, there is also a linux version for shutter encoder but the python script looks cooler.

Hey Des. Give this a go: find_and_replace_mediahub.zip (13.2 KB)

Extract this to: /opt/Autodesk/shared/python or /opt/Autodesk/user/your_user/python

Doing a find and replace was quick because I already had most of this built. Adding renumbering with padding options is definitely possible, but I’ll need more free time.

Hi John,
Thanks for this!
Its not working for me atm unfortunately:(
I get the dialogue popup, enter details and hit rename, but nothing changes. Does it need permisssions or anything? Or perhaps its because I’m only wanting to replace some (not all) of the name?
here’s the output from the flame terminal, if thats useful:

>>>>>>>>>>>>>>>>>>>> Find and Replace MediaHub v0.1 <<<<<<<<<<<<<<<<<<<<
>>> config loaded <<<
→ config saved


File Path: /mnt/StorageMedia/temp/s3_ep1_col_tests/test 1/
Find Me: test
Replace With Me: UPDATE
New File Name:
New File Path: /mnt/StorageMedia/temp/s3_ep1_col_tests/test 1/
**************** Find and Replace End ****************

The files I’m pointing at are of the form:
pretitles test nr_####.exr

So I would expect to get:
pretitles UPDATE nr_####.exr

ta
Des

It looks like you’re selecting a folder and not selecting files. Is that right?

Are there spaces in the file name? I didn’t test that, but it should work.

Are you able to change a name in the “finder?”

aah, that works now on files if viewed as frames, but not when they’re presented as a sequence. I was running this on already fixed files so they’re appearing as a sequence, but switching to frames works.
spaces seem to be ok too:

File Path: /mnt/StorageMedia/temp/s3_ep1_col_tests/test 1/updated 000005.exr
Find Me: updated
Replace With Me: renamed_and_tested with spaces
New File Name: renamed_and_tested with spaces 000005.exr
New File Path: /mnt/StorageMedia/temp/s3_ep1_col_tests/test 1/renamed_and_tested with spaces 000005.exr

So to fix my original bad files which were of the form
pretitles test_####_nr.exr
I’d need to run this twice, once to amend the name, and again to remove the _nr.

Des

Exactly.

Yep, it won’t work on sequences - only frames or individual files. Glad it’s working for you.

Thanks, very cool!
Des

1 Like

Not sure what version you are running, nor which are applicable, but in my CentOS 8, the file manager in the UI has a search and replace feature in the rename dialoge.

2 Likes

Im on centos 7.6 but yes dolphin has this. Nice!
thanks
Des

Here are two scripts:

  1. Slight tweak to Find & Replace. Now it doesn’t show up if a sequence is selected.
  2. Sequence Renamer with Start Frame and Padding options.

mediahub_renamers.zip (25.9 KB)

2 Likes

Hi John,
these work a treat.
thanks very much!
Des

1 Like