Startup lingering

When starting up, Flame goes through a process:
Executing command: …/bin/sanitize_shared_SynColor_transforms
Preserving ./project_name_4ND_5H1TL04D_0F_H3X4D3C1M4LS…
Preserving ./project_name_4ND_5H1TL04D_0F_H3X4D3C1M4LS…
Preserving ./project_name_4ND_5H1TL04D_0F_H3X4D3C1M4LS…
Preserving ./project_name_4ND_5H1TL04D_0F_H3X4D3C1M4LS…
Lingers for several seconds on each directory. Apparently even deleted projects have such named directories that are still checked.
Network licensed Mac machine, didn’t happen when the same machine had a node-locked license.
Any way to get rid of this time consuming process or the folders themselves?


@Sinan Possibly a DNS issue? This exact thing has started happening on our Flames at the same time our DNS/DCHP server died.

1 Like

Thanks for the input we’ll look into that. Though it seems to be related to SynColor setups on the local machine.

I wonder if it’s OK to just delete the folders that are being accessed.

“I wonder if it will be friends with me?”

  • The whale, Hitchhiker’s Guide to the Galaxy

Thought I’d drop an update if it helps at all, as it seems i’ve solved my startup lingering.

I stood up a new DNS server last night on a new IP and set Flame’s resolv.conf file to point to it. Flame is now starting without hanging. When I comment out the DNS IP to simulate no DNS server, it starts to hang again.

I did notice some weird stuff happening though, I think it’s the Network Manager Service…

When I restart the network or the machine resolv.conf resets to a previous DNS IP address.
I had to update the IP then use chattr +i /etc/resolv.conf to make the file read only (if you need to write to it again use chattr -i /etc/resolv.conf to remove the immutable flag).
Also needed to add PEERDNS=no to the ifcfg file for my network interface.

Hope something in there helps!


Thanks for the update. I bit the bullet and removed the sym-links to the remote directories and system check just went through. Though using Flame will create new links, so I will try the more elegant and technically correct way of doing it. Thanks again @Collict



Sorry to revive an old thread but I had the same issue and thought I’d share my solution if anybody else comes across this.

Here’s how we managed to solve it on macOS Monterey:
System preferences → Network → Select “Ethernet 1” → Advanced → DNS
Under DNS-servers click the little + and we added the IP to out router as the first entry.

I’m no network expert so I can’t describe what this does, but as far as I understand it this forces the computer to ask the router for a DNS instead of having it automatically assigned. Or something :smile:

Hope this is of help for somebody!