Sticky Compass in the user bin

Hey all, whenever I save a compass group to my user bin, I often end up untangling them. It doesn’t happen to all of the compasses or all the setups. Anyone know what is causing this?

2 Likes

Arrgh yeah that is very frustrating @digitalbanshee

I don’t have a satisfying solution for you but it is happening because it will drop the setup/compass as soon as you drag it out of the user bin. The only suggestion I have is to sit in a blank space before you bring out the compass.

I guess it is just the nature of how a compass works and unfortunately it is grouping and moving not just the nodes from the user bin, contained in your compass but also any nodes that get caught up in the compass as soon as it appears on the schematic.

Maybe someone knows of a hotkey that I don’t ¯\_(ツ)_/¯

It is frustrating with compass but I get it appending setups. I can even be sitting in the furthest most remote part of my schematic and when I paste there is a 50-50 chance it will past over the top of my existing setup rather than in my clean empty space :weary:

When you drag the setup out of the bin keep the pen down and then drop the compass away from the other nodes

I also have the situation where no matter how far away from my nodes I am, it will randomly grab a group of them and tangle it up. Oh well, at least we’re all seeing it. :stuck_out_tongue:

My workaround is to open them in a new empty batch group and copy-paste it where I need it.

2 Likes

I can’t reproduce the problem you are seeing. Did you try holding the pen down and waiting for the compass to show?

It does not happen every time. In the same setup, I can get it to happen and not happen. I’ve tried putting the nodes in the batch setup into a compass first too. If it IS going to happen, it happens the minute you drag out the compass, while you’re holding down the pen. It’s immediately tangled and there is nothing to do but let go.

1 Like

As a temporary workaround, have you tried selecting all the nodes in bfx and drag them down/away from the center and then pull out the node from the bin?
Other question…are you on 2022?
I used to have the same problem on the 2022… on 2023 seems to works fine.

2022.3.1 Mac.

yep this is my workaround as well

2 Likes

Hello digitalbanshee!

I haven’t had that happen although I don’t use Compass all that often.

It’s a longshot but… could this be caused by the specific node you grabbed to drag the Compass to your user bin?

Try adding a Mux external to the Compass canvas (like a “Compass in” or “Compass out” node) and make one of those selected (hilighted) before dragging the whole thing to your user bin.

1 Like

Or maybe even just remove the compass before putting it in the user or project bin? Easy enough to draw it again if you really need it labelled I suppose. I sort of feel like once the rig is just basically a node in the user bin- the compass is just doubling down on that functionality and making a mess when you try to pull it into a batch.

And you can actually remove a a group of nodes from a compass using the same hot keys you would use to remove a node from a node tree. I think it’s just an annoying bug, and then the compasses become the glue trap that exponentially makes it even stickier and messier.

1 Like