Symbol lookup error: /lib64/ undefined symbol: _glapi_tls_Current - flame install with RTX 3080

No matter what i do or how i get there after i install flame on centos 7.6 I get this error
“symbol lookup error: /lib64/ undefined symbol: _glapi_tls_Current”

i have tried with flame 2022 and flame 2023 + various versions of the DKU + different nvidia drivers.
The autodesk solution each time seems to be a full reinstall which i’ve done and it has still failed. There was mention that it could be related to a firefox upate, but i haven’t touched that all. My gut tells me it’s something to do with my nvidia driver since i have a rtx 3080 and needed something different. If i don’t use that nvidia driver my system doesn’t seem to want to boot and hangs in different processes.
has anyone else ever experienced anything remotely close to this?

@andrewc has also been amazing and helping me out so i couldn’t have gotten this far without him…i owe him so many beers.

1 Like

Interesting. There are a few 30XX installs out there. I’d adjust the topic title to include the 3080 but to increase visibility.

you have to have the --install-libglvnd flag set when installing the drivers. I don’t think you can do this by just running the DKU, unfortunately.

To do this:
Enable multi-user mode by running this command as root:

systemctl set-default

Reboot the system. This will mean xorg won’t load so you are able to update the driver.

Change directory to where the DKU’s nvidia driver is (I believe its (DKU folder)/bin/system-rpm/ ?)

Run the driver install.
./ --install-libglvnd

I think its executable already but if its not you may have to do
chmod +x

Press yes to everything. Once it installs you can enable graphical mode again

systemctl set-default

and reboot!

Give me a bell if you need any more info


ok…so this is what happened. a hybrid of sorts.
thank you so much @friendlyape and @andrewc for all your help.
these were my steps for anyone in a similar situation…
install centos 7.6 (modified with mce=off and mce=nobootlog) so i could get it to work with my Ryzen 5950.
then installed DKU 17.0
unfortunately this doesn’t play too nicely with my RTX 3080 and it ends up hanging on boot up so
i had to use the “install-libglvnd” flag so that i could use my Nvidia Driver. I still couldn’t use the one from the DKU, but this worked and was able to proceed with flame install with success.
It was not pretty getting here, but glad it worked.

1 Like

Glad you got there! so, what version of the Nvidia driver are you using? one supplied by Autodesk in the DKU? or one downloaded from Nvidia?

I ask because I have found that when I have used the latest driver downloaded from Nvidia, I can’t use the planar tracker in action or gmask tracer (it always says failed to set reference). Would be interested to hear if you have those issues.

Use RockyLinux… CentOS 7.6 is ancient.

i know, but i had different issues there. couldn’t get the installer passed 97%.

i’m using the latest RTX 30 series driver for linux. i downloaded from nvidia.
the planar tracker worked in action for me as did gmask tracer.
i had to use the nvidia driver outside the DKU for my system to boot.

1 Like

Nice, thanks for that. I tried it myself and can confirm.

oh sweet. i’m glad you helping me ended up helping you too.

1 Like

I have a problem now with new Autodesk ISO install of Rocky Linux 8.5 Rev2 to upgrade Nvidia drivers. I used the same procedure as before going into systemctl set-default as root and rebooting. After I run the install Nvidia drivers with a --install-libglvnd command it goes tru the uncompressing… and then I get this error:
ERROR: An Nvidia kernel module ‘nvidia-uvm’ appears to be already loaded in your kernel. This may be because it is in use bla bla… but this may also happen if your kernel was configured without support for module unloading…

There is probably a process still using the drivers. Make sure you shutdown all adsk processes. Backburner, Wiretap, SW, etc.

1 Like

and when you reboot, does it load into a tty? or does the desktop load?
whats the output of nvidia-smi?

1 Like

yes as before it goes into a tty and I log in and go into root with sudo su and start the driver update with those flags from above. nvidia-smi shows that deamon is running in driver persistance mode - name of the GPU shows as Persistance-M if I remember. I have found documentation for Driver Persistance and used those commands to disable but still it sticks so it is a demon that starts and connects the driver to kernel modules as I understand. I am not sure what to do to disable it.

I try this:
and this:

is this change part of new DKU or Rocky Linux Autodesk ISO Revision2 - before I had Rev1 and did not have problems.

---- LOG

nvidia-installer log file ‘/var/log/nvidia-installer.log’
creation time: Mon Nov 7 15:46:23 2022
installer version: 515.76

PATH: /usr/share/Modules/bin:/lib/modules/4.18.0-348.20.1.el8_5.x86_64/aja/current/bin:/opt/Autodesk/io/bin:/opt/Autodesk/sw/tools:/opt/Autodesk/sw:/sbin:/bin:/usr/sbin:/usr/bin

nvidia-installer command line:

Using: nvidia-installer ncurses v6 user interface
→ Detected 48 CPUs online; setting concurrency level to 32.
ERROR: An NVIDIA kernel module ‘nvidia-uvm’ appears to already be loaded in your kernel. This may be because it is in use (for example, by an X server, a CUDA program, or the NVIDIA Persistence Daemon), but this may also happen if your kernel was configured without support for module unloading. Please be sure to exit any programs that may be using the GPU(s) before attempting to upgrade your driver. If no GPU-based programs are running, you know that your kernel supports module unloading, and you still receive this message, then an error may have occurred that has corrupted an NVIDIA kernel module’s usage count, for which the simplest remedy is to reboot your computer.
ERROR: Installation has failed. Please see the file ‘/var/log/nvidia-installer.log’ for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at

Yes and I try all kinds of kill commands and it just starts the server again as soon as it is killed. I really do not know how to proceed with updating drivers on this box

OK somehow the driver is still being loaded.
In your grub boot parameters do you have rd.blacklist.driver=nouveau and nouvea.modeset=0?

Look at he lsfo -n -w command and PID even if I kill that PID sw_server and look again it respawns it under a different one.

I will look at the grub boot I think I saw that line when I checked it by typing e before it boots.

whats the output of?
/bin/systemctl status "*sw_*"
If you see any sw related service running you can do:
/bin/systemctl stop “service”

Alternatively, I usually do the NVIDIA update like so:
1 - Stop all autodesk services (Services App)
2 - Go into multiuser mode by typing init 3 in the terminal
3 - Install the driver
4 - Reboot sudo reboot