Tangent No Hub Connection

title says it. I’ve not used it in a very long time. But I’m in the office now and I get no connection.

Now I’ve started the TangentHub manually. Not all modules seem to work. Also I’ve gotten an extreme slowdown in the pen and mouse, in addition to the panel itself, which is sort of working. But not fully.

Happens on my Linux box from time to time. Running tangent hub in a terminal window solves it until I can reboot. It brings everything back, not just some parts. So if you’re missing other modules, there may be more to it.

Systemctl stop tangenthub
Systemctl start tangenthub

As root. Do it twice (stop, start, stop, start) and all your ills should be gone, assuming your panel isn’t kaputt.

1 Like

Same for me on linux rocky. Flame 2024.2
I always have to restart the hub.
Painful when you don’t have the root pwd of your Machine.

I get command not found for Systemctl

It’s actually

/etc/init.d/tangenthub start stop or restart

But thank you

case sensitive

It did used to be that. What os/flame version are you on?

Still is the correct command on current Rock 8.7. Just tried it and worked for me.

Got it from the horses mouth (Stephane)

They moved all of the other services off of /etc/init.d a couple versions ago to systemctl:

You can start/stop/restart tangenthub that way at least on my linux box/version of flame. /etc/init.d appears to still work too, so that’s neat!

1 Like