Write file always brings whole range back in

hi all. so ive gone over to rendering batch files out as a write file. and great it brings it back in, but if I stop the render say its a 200 frame render and I stop it at100. the clip in the batch render reel is 200 frames with 100 frames of checkerboard frames. not great. in my folder on the disk its only 100 frames. how do you get round this or do I have to wait for 2023.2.1

1 Like

I am not on this version @Jonhollis so I don’t understand the ins and outs but is this a new feature of 2023.2? That the write node brings the footage back in or is this a Python script you have installed?

I get this behaviour only when bringing the OpenClip back in.

I have a Python script installed, Import_open_clip.py version = v1.5, that brings my rendered footage back in. It has a few quirks that makes me think you have a different problem.

I can’t interrupt my render else my OpenClip doesn’t get written (I think this happens at the end of the render not the start).

The first time I render it creates an OpenClip (if I enable) and that first time dictates what length my OpenClips are. If I shorten my render the OpenClip get padded. Similar to what you are describing. I can still access my rendered files and if I avoid the OpenClip I get a sequence as expected, without any padding.

1 Like

im using the latest version which has the write file ability to auto import back in again. ive tried it with create open clip and without and still the same. im going to have to go back to rendering normally!

I believe that the frame range of the write file node sets what the frame range of the expected “container” for the reimported clip.

Hello @Jonhollis

Please report the issue to the support team and we will have a look.