2023 - problems installing logik matchbox and ML TW

hey all. I’m getting these errors when trying to install logik matchbox collection and the TW ML stuff with the new software - any ideas…

You could try using the Logik Portal to install the Logik Matchboxes:

1 Like

on that web page the link doesn’t work!\

Try it now

I believe the Matchbox installer just copies the shaders to /opt/Autodesk/presets//matchbox/shaders/LOGIK/ does it not?

You don’t even need root to copy there.

I just thought I should let people know it appears to be broken

1 Like

If you start matchbox shaders being installed via the Logic Portal Python Script, use “/opt/Autodesk/presets/2023/matchbox/shaders” link to install. After allowing writing on protected folder all the shaders will be installed. We did it already on latest macOS Catalina and Flame 2023.

1 Like

Why not just edit the location here in preferences.

Yeah the script just needs to be updated to call python3 instead of python

To fix it I created an alias so that “python” ran “python3” and then it worked.

Edit: Actually I remembered I tried that and I think it will work but I actually just changed the “#!/usr/bin/env python” to “#!/usr/bin/env python3” in Visual Studio Code and just ran it right within VSC and it worked perfect.

is there a solution for those who don’t speak Python?

as mentioned above, just edit the INSTALL.command file and change “#!/usr/bin/env python” to “#!/usr/bin/env python3”

3 Likes

Hello. Just started playing with 2023. Is there a “good” installer for the Login Matchbox set?

Have you tried using the install that you get with @MikeV 's portal?

Define “good”? What’s wrong with the logik-matchbook installer?

Doesn’t work. It’s looking for an old python folder or something. Same with time warp ml. Looking for a documents folder that can’t exist.

Linux or mac? . I’ve reinstalled my system recently and matchbox and twml installer worked perfectly. Rocky linux and 2023 now and centos 8.2 and 2022 before. Matchbox installer always worked in mac :man_shrugging:

Mac

1 Like

Try editing the install script and change the first line that’s has “python” in it to “python3” see if that might work.

1 Like